summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-05-14 08:11:50 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-05-14 08:11:50 +0000
commited0a05ea77f5dfebe03e7e274194f9229d689a8a (patch)
tree4bf13a1ea969d90f8084e763878244419823f6ad /dev-java
parentInitial import. (diff)
downloadgentoo-2-ed0a05ea77f5dfebe03e7e274194f9229d689a8a.tar.gz
gentoo-2-ed0a05ea77f5dfebe03e7e274194f9229d689a8a.tar.bz2
gentoo-2-ed0a05ea77f5dfebe03e7e274194f9229d689a8a.zip
Initial import.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdbc-postgresql/ChangeLog22
-rw-r--r--dev-java/jdbc-postgresql/Manifest5
-rw-r--r--dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-2.7.31
-rw-r--r--dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-3.7.31
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-2.7.3.ebuild24
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-3.7.3.ebuild24
6 files changed, 75 insertions, 2 deletions
diff --git a/dev-java/jdbc-postgresql/ChangeLog b/dev-java/jdbc-postgresql/ChangeLog
new file mode 100644
index 000000000000..3d798e7bbeff
--- /dev/null
+++ b/dev-java/jdbc-postgresql/ChangeLog
@@ -0,0 +1,22 @@
+# ChangeLog for dev-java/jdbc-postgresql
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.1 2003/05/14 08:11:46 absinthe Exp $
+
+*jdbc-postgresql-3.7.3 (14 May 2003)
+
+ 14 May 2003; Dylan Carlson <absinthe@gentoo.org>
+ jdbc-postgresql-2.7.3.ebuild, jdbc-postgresql-3.7.3.ebuild:
+ Initial import.
+
+ Important notice about version numbers:
+
+ * The first digit of the version number states what JDBC driver it is (i.e., 2
+ for JDBC2, 3 for JDBC3). Different drivers are slotted, therefore you can
+ install both a JDBC2 and JDBC3 driver on the same machine.
+
+ * The remaining digits are the version numbers, which will typically
+ correspond to a release of PostgreSQL.
+
+ Most people will want to use the JDBC2 drivers. JDBC3 drivers only work with
+ the 1.4 JVMs.
+
diff --git a/dev-java/jdbc-postgresql/Manifest b/dev-java/jdbc-postgresql/Manifest
index d183dfd25e6f..7b0afbc55bce 100644
--- a/dev-java/jdbc-postgresql/Manifest
+++ b/dev-java/jdbc-postgresql/Manifest
@@ -1,4 +1,5 @@
-MD5 ff8e130652e975cbba9010f1912cc2e8 jdbc-postgresql-2.7.3.ebuild 540
-MD5 827dc42b4c76c711cdfb8ff339cc95cf jdbc-postgresql-3.7.3.ebuild 540
+MD5 c74aa0644c4066396f6de8fd8ba7beb4 jdbc-postgresql-2.7.3.ebuild 658
+MD5 810ed0e1edec6997a2b32644b1b200bb jdbc-postgresql-3.7.3.ebuild 658
+MD5 bafdc6c4b542d65ec4cef4031ae14bd5 ChangeLog 881
MD5 97025d204bd6ed6c78530c5131b95b23 files/digest-jdbc-postgresql-2.7.3 58
MD5 927470f50a83ea9bf353f3d3e8c68c4f files/digest-jdbc-postgresql-3.7.3 58
diff --git a/dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-2.7.3 b/dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-2.7.3
new file mode 100644
index 000000000000..a19bcc7f9e28
--- /dev/null
+++ b/dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-2.7.3
@@ -0,0 +1 @@
+MD5 d3767ab2cadc9075b47fda7befd15c40 pg73jdbc2.jar 163980
diff --git a/dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-3.7.3 b/dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-3.7.3
new file mode 100644
index 000000000000..fe1e8e171281
--- /dev/null
+++ b/dev-java/jdbc-postgresql/files/digest-jdbc-postgresql-3.7.3
@@ -0,0 +1 @@
+MD5 6c9874b88a3bf855e0a07196cb5ec11d pg73jdbc3.jar 184176
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-2.7.3.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-2.7.3.ebuild
new file mode 100644
index 000000000000..9700f897f470
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-2.7.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-2.7.3.ebuild,v 1.1 2003/05/14 08:11:46 absinthe Exp $
+
+inherit java-pkg
+
+At="pg73jdbc2.jar"
+S=${WORKDIR}
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${At}"
+HOMEPAGE="http://jdbc.postgresql.org/"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+LICENSE="GPL-2"
+SLOT="2"
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.2"
+
+src_compile() {
+ einfo "This is a binary-only ebuild (for now)."
+}
+
+src_install() {
+ java-pkg_dojar ${DISTDIR}/${At}
+}
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-3.7.3.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-3.7.3.ebuild
new file mode 100644
index 000000000000..7e27ea7e5555
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-3.7.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-3.7.3.ebuild,v 1.1 2003/05/14 08:11:46 absinthe Exp $
+
+inherit java-pkg
+
+At="pg73jdbc3.jar"
+S=${WORKDIR}
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${At}"
+HOMEPAGE="http://jdbc.postgresql.org/"
+KEYWORDS="x86 ppc sparc alpha mips hppa arm"
+LICENSE="GPL-2"
+SLOT="3"
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ einfo "This is a binary-only ebuild (for now)."
+}
+
+src_install() {
+ java-pkg_dojar ${DISTDIR}/${At}
+}