summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-02-02 11:53:04 +0000
committerVlastimil Babka <caster@gentoo.org>2008-02-02 11:53:04 +0000
commitd6ab5fd364cb90ca30390fc1d31f728a7917d913 (patch)
tree8782ed5127c3f9156cfdb46891c44fe709316176 /dev-java
parentFix blocker, bug #207259 (diff)
downloadgentoo-2-d6ab5fd364cb90ca30390fc1d31f728a7917d913.tar.gz
gentoo-2-d6ab5fd364cb90ca30390fc1d31f728a7917d913.tar.bz2
gentoo-2-d6ab5fd364cb90ca30390fc1d31f728a7917d913.zip
Version bump and migration to gen-2 eclasses, bug #168655. Dropped ppc due to nekohtml dep.
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xmlc/ChangeLog11
-rw-r--r--dev-java/xmlc/files/xmlc-2.3-build.xml.patch51
-rw-r--r--dev-java/xmlc/xmlc-2.3.ebuild70
3 files changed, 130 insertions, 2 deletions
diff --git a/dev-java/xmlc/ChangeLog b/dev-java/xmlc/ChangeLog
index 94867730cd3d..b57aed658c48 100644
--- a/dev-java/xmlc/ChangeLog
+++ b/dev-java/xmlc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/xmlc
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlc/ChangeLog,v 1.5 2007/02/21 23:47:28 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlc/ChangeLog,v 1.6 2008/02/02 11:53:03 caster Exp $
+
+*xmlc-2.3 (02 Feb 2008)
+
+ 02 Feb 2008; Vlastimil Babka <caster@gentoo.org>
+ +files/xmlc-2.3-build.xml.patch, +xmlc-2.3.ebuild:
+ Version bump and migration to gen-2 eclasses, bug #168655. Dropped ppc due
+ to nekohtml dep.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-java/xmlc/files/xmlc-2.3-build.xml.patch b/dev-java/xmlc/files/xmlc-2.3-build.xml.patch
new file mode 100644
index 000000000000..125fd3862a58
--- /dev/null
+++ b/dev-java/xmlc/files/xmlc-2.3-build.xml.patch
@@ -0,0 +1,51 @@
+diff -Naur xmlc-src-2.3.orig/xmlc/modules/taskdef/build-default.properties xmlc-src-2.3/xmlc/modules/taskdef/build-default.properties
+--- xmlc-src-2.3.orig/xmlc/modules/taskdef/build-default.properties 2007-04-22 00:40:58.000000000 +0200
++++ xmlc-src-2.3/xmlc/modules/taskdef/build-default.properties 2008-02-02 10:41:25.000000000 +0100
+@@ -37,7 +37,7 @@
+ # Comma seperated list of libraries (or more exactly, include patterns) this
+ # module depends on for building.
+ # They are searched relative to ${lib.dir}
+-module.depends=xmlc.jar
++module.depends=xmlc.jar,ant.jar
+
+ # Javadoc settings
+ javadoc.packages=org.enhydra.*
+diff -Naur xmlc-src-2.3.orig/xmlc/modules/xmlc/build.xml xmlc-src-2.3/xmlc/modules/xmlc/build.xml
+--- xmlc-src-2.3.orig/xmlc/modules/xmlc/build.xml 2007-04-23 00:08:08.000000000 +0200
++++ xmlc-src-2.3/xmlc/modules/xmlc/build.xml 2008-02-02 10:32:19.000000000 +0100
+@@ -148,15 +148,12 @@
+ description="Build the module .jar file">
+ <tstamp/>
+ <delete file="${module.jar}"/>
+- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpath="${build.lib.dir}/jarjar.jar"/>
+- <jarjar jarfile="${module.jar}"><!-- index="true"-->
++ <jar destfile="${module.jar}"><!-- index="true"-->
+ <fileset file="${dist.root}/../LICENSE-xmlc"/>
+ <fileset dir="${build.classes}" />
+ <fileset dir="${src.dir}"
+ includes="${module.lib.extra.includes}"
+ excludes="${module.lib.extra.excludes}" />
+- <zipfileset src="${build.lib.dir}/asm.jar"/>
+- <rule pattern="org.objectweb.asm.**" result="org.enhydra.xml.xmlc.deferredparsing.asm.@1"/>
+ <manifest>
+ <attribute name="Built-By" value="${user.name}"/>
+ <attribute name="Built-On" value="${TODAY}"/>
+@@ -172,17 +169,12 @@
+ <attribute name="Implementation-Vendor-Id" value="org.objectweb"/>
+ <attribute name="Implementation-URL" value="http://www.enhydra.org/tech/xmlc/"/>
+ </section>
+- <section name="org/enhydra/xml/xmlc/deferredparsing/asm/">
+- <attribute name="Implementation-Title" value="ASM"/>
+- <attribute name="Implementation-Version" value="3.0"/>
+- <attribute name="Implementation-Vendor" value="France Telecom R&amp;D"/>
+- </section>
+ </manifest>
+ <!--indexjars>
+ <fileset dir="${dist.root}/lib" includes="*.jar"/>
+ <fileset dir="${dist.root}/build-lib" includes="*.jar"/>
+ </indexjars-->
+- </jarjar>
++ </jar>
+ </target>
+
+ <target name="lib-tests" depends="init,compile-tests" unless="lib-test.skip"
diff --git a/dev-java/xmlc/xmlc-2.3.ebuild b/dev-java/xmlc/xmlc-2.3.ebuild
new file mode 100644
index 000000000000..806f8beed139
--- /dev/null
+++ b/dev-java/xmlc/xmlc-2.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlc/xmlc-2.3.ebuild,v 1.1 2008/02/02 11:53:03 caster Exp $
+
+EAPI="1"
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Open Source Java/XML Presentation Compiler"
+HOMEPAGE="http://xmlc.objectweb.org/"
+SRC_URI="http://download.forge.objectweb.org/${PN}/${MY_P}.zip
+ http://download.us.forge.objectweb.org/${PN}/${MY_P}.zip"
+
+COMMON_DEP="dev-java/xerces:2
+ dev-java/gnu-regexp:1
+ java-virtuals/servlet-api:2.3
+ dev-java/log4j:0
+ dev-java/xml-commons-resolver:0
+ dev-java/nekohtml:0
+ dev-java/asm:3"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # get rid of jarjar, and add ant.jar to the taskdef module's classpath
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ cd "${S}"/release/build-lib/ || die
+ rm -v *.jar || die
+
+ java-pkg_jar-from xerces-2,gnu-regexp-1,log4j,nekohtml,asm-3
+ java-pkg_jar-from xml-commons-resolver xml-commons-resolver.jar resolver.jar
+ java-pkg_jar-from --virtual servlet-api-2.3 servlet.jar
+ java-pkg_jar-from --build-only ant-core ant.jar
+}
+
+EANT_BUILD_TARGET="all-libs"
+
+src_install() {
+ # the rest of jars are included in all-runtime
+ java-pkg_dojar release/lib/{xmlc-all-runtime,xmlc-taskdef}.jar
+ java-pkg_register-ant-task
+
+ newdoc xmlc/modules/xmlc/README.XMLC README || die
+ dodoc xmlc/modules/xmlc/ChangeLog || die
+ dohtml release/release-notes/xmlc-${PV/./-}-release-note.html \
+ xmlc/bugs/bugs.html || die
+
+ # move the generated documentation around
+ if use doc; then
+ mv ${PN}/modules/taskdef/doc ${PN}/modules/${PN}/doc/taskdef || die
+ mv ${PN}/modules/wireless/doc ${PN}/modules/${PN}/doc/wireless || die
+ mv ${PN}/modules/xhtml/doc ${PN}/modules/${PN}/doc/xhtml || die
+ java-pkg_dohtml -r ${PN}/modules/xmlc/doc/* || die "Failed to install documentation"
+ fi
+}