summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-09-07 15:26:13 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-09-07 15:26:13 +0000
commita80629965be07bb1dbe702fecd5063439ddd0965 (patch)
tree4c86de0909bde00dc83074d126daab4d7cf8b936 /dev-java
parentReplace emul-linux-x86-compat dependency by virtual/libstdc++, bug 522218. (diff)
downloadgentoo-2-a80629965be07bb1dbe702fecd5063439ddd0965.tar.gz
gentoo-2-a80629965be07bb1dbe702fecd5063439ddd0965.tar.bz2
gentoo-2-a80629965be07bb1dbe702fecd5063439ddd0965.zip
EAPI bump, some qa
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jgoodies-animation/ChangeLog10
-rw-r--r--dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-java/jgoodies-animation/ChangeLog b/dev-java/jgoodies-animation/ChangeLog
index 213840e42a38..599646377974 100644
--- a/dev-java/jgoodies-animation/ChangeLog
+++ b/dev-java/jgoodies-animation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jgoodies-animation
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/ChangeLog,v 1.11 2007/10/24 05:11:59 wltjr Exp $
+# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/ChangeLog,v 1.12 2014/09/07 15:26:13 ercpe Exp $
+
+*jgoodies-animation-1.2.0-r1 (07 Sep 2014)
+
+ 07 Sep 2014; Johann Schmitz <ercpe@gentoo.org>
+ +jgoodies-animation-1.2.0-r1.ebuild:
+ EAPI bump, some qa
24 Oct 2007; William L. Thomson Jr. <wltjr@gentoo.org>
-jgoodies-animation-1.1.3.ebuild:
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..a09e87067798
--- /dev/null
+++ b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/jgoodies-animation-1.2.0-r1.ebuild,v 1.1 2014/09/07 15:26:13 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_V=${PV//./_}
+
+DESCRIPTION="JGoodies Animation Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/animation-${MY_V}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )"
+
+RDEPEND=">=virtual/jre-1.4
+ examples? (
+ >=dev-java/jgoodies-binding-1.1:1.0
+ >=dev-java/jgoodies-forms-1.0:0
+ )"
+
+S="${WORKDIR}/animation-${PV}"
+
+EANT_FILTER_COMPILER="jikes"
+EANT_DOC_TARGET=""
+
+java_prepare() {
+ find -name "*.jar" -delete || die
+}
+
+src_test() {
+ eant test -Djunit.jar.present=true \
+ -Djunit.jar=$(java-pkg_getjar junit junit.jar)
+}
+
+src_install() {
+ java-pkg_dojar build/animation.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml README.html || die
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/core/*
+ use examples && java-pkg_doexamples src/tutorial
+}