summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-02-23 21:48:51 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-02-23 21:48:51 +0000
commit6d760829e8b30f19fc3dc41fec7daf5ecfc5ce07 (patch)
treeceb3d234160a7fddcf874803562941034ac77346 /dev-java
parentAdd missing mdnsd.init.d, and use function "newinitd" to install it. (diff)
downloadgentoo-2-6d760829e8b30f19fc3dc41fec7daf5ecfc5ce07.tar.gz
gentoo-2-6d760829e8b30f19fc3dc41fec7daf5ecfc5ce07.tar.bz2
gentoo-2-6d760829e8b30f19fc3dc41fec7daf5ecfc5ce07.zip
removed junit support to fix #82219
(Portage version: 2.0.51.16)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-validator/ChangeLog6
-rw-r--r--dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild20
-rw-r--r--dev-java/commons-validator/commons-validator-1.1.3.ebuild9
3 files changed, 17 insertions, 18 deletions
diff --git a/dev-java/commons-validator/ChangeLog b/dev-java/commons-validator/ChangeLog
index 5537d922ffce..fc6d3ca89bcb 100644
--- a/dev-java/commons-validator/ChangeLog
+++ b/dev-java/commons-validator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-validator
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.19 2005/01/01 18:19:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.20 2005/02/23 21:48:51 luckyduck Exp $
+
+ 23 Feb 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ commons-validator-1.0.2-r3.ebuild, commons-validator-1.1.3.ebuild:
+ removed junit support to fix #82219
30 Nov 2004; Sven Wegener <swegener@gentoo.org>
commons-validator-1.0.2-r3.ebuild, commons-validator-1.1.3.ebuild:
diff --git a/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild b/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild
index 4740f1da9270..c803b972a98e 100644
--- a/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild
+++ b/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild,v 1.10 2005/01/01 18:19:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild,v 1.11 2005/02/23 21:48:51 luckyduck Exp $
inherit java-pkg
@@ -10,8 +10,7 @@ SRC_URI="mirror://apache/jakarta/commons/validator/source/${PN}-${PV}-src.tar.gz
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
app-arch/zip
- jikes? ( dev-java/jikes )
- junit? ( >=dev-java/junit-3.7 )"
+ jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jre-1.3
>=dev-java/oro-2.0.6
>=dev-java/commons-digester-1.0
@@ -22,26 +21,25 @@ RDEPEND=">=virtual/jre-1.3
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~amd64"
-IUSE="doc jikes junit"
+IUSE="doc jikes"
S="${WORKDIR}/${P}-src"
src_unpack() {
unpack ${A}
cd ${S}
- echo "oro.jar=`java-config --classpath=oro`" >> build.properties
- echo "commons-digester.jar=`java-config --classpath=commons-digester`" >> build.properties
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" >> build.properties
- echo "commons-logging.jar=`java-config --classpath=commons-logging | sed s/.*://`" >> build.properties
- echo "commons-beanutils.jar=`java-config --classpath=commons-beanutils`" >> build.properties
- echo "xerces.jar=`java-config --classpath=xerces-2`" >> build.properties
+ echo "oro.jar=`java-config -p oro`" >> build.properties
+ echo "commons-digester.jar=`java-config -p commons-digester`" >> build.properties
+ echo "commons-collections.jar=`java-config -p commons-collections`" >> build.properties
+ echo "commons-logging.jar=`java-config -p commons-logging | sed s/.*://`" >> build.properties
+ echo "commons-beanutils.jar=`java-config -p commons-beanutils`" >> build.properties
+ echo "xerces.jar=`java-config -p xerces-2`" >> build.properties
}
src_compile() {
local antflags="compile"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
- use junit && antflags="${antflags} test"
ant ${antflags} || die "build failed"
}
diff --git a/dev-java/commons-validator/commons-validator-1.1.3.ebuild b/dev-java/commons-validator/commons-validator-1.1.3.ebuild
index 1137fb69ae32..1f3abedf5b86 100644
--- a/dev-java/commons-validator/commons-validator-1.1.3.ebuild
+++ b/dev-java/commons-validator/commons-validator-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.3.ebuild,v 1.7 2005/01/01 18:19:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.3.ebuild,v 1.8 2005/02/23 21:48:51 luckyduck Exp $
inherit java-pkg
@@ -9,8 +9,7 @@ HOMEPAGE="http://jakarta.apache.org/commons/validator/"
SRC_URI="mirror://apache/jakarta/commons/validator/source/${PN}-${PV}-src.tar.gz mirror://gentoo/commons-validator-1.1.3-gentoo-missingfiles.tar.bz2"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
- jikes? ( dev-java/jikes )
- junit? ( >=dev-java/junit-3.8.1 )"
+ jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jre-1.3
>=dev-java/oro-2.0.8
>=dev-java/commons-digester-1.5
@@ -21,7 +20,7 @@ RDEPEND=">=virtual/jre-1.3
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="doc jikes junit"
+IUSE="doc jikes"
src_unpack() {
unpack ${A}
@@ -35,14 +34,12 @@ src_unpack() {
echo "commons-logging.jar=`java-config --classpath=commons-logging | sed s/.*://`" >> build.properties
echo "commons-beanutils.jar=`java-config --classpath=commons-beanutils | sed s/.*://`" >> build.properties
echo "xerces.jar=`java-config --classpath=xerces-2`" >> build.properties
- use junit && echo "junit.jar=`java-config --classpath=junit`" >> build.properties
}
src_compile() {
local antflags="compile"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
- use junit && antflags="${antflags} test"
ant ${antflags} || die "build failed"
jar -cvf ${PN}.jar -C target/classes/ . || die "could not create jar"
}