summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-01-12 20:28:03 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-01-12 20:28:03 +0000
commit5a553ed9d7eda22074979b57bf19f1904cddf97e (patch)
treedee2be300814ec47d89bda6edd77c1ec39dd28d9 /dev-java
parentamd64 stable, bug #495966 (diff)
downloadgentoo-2-5a553ed9d7eda22074979b57bf19f1904cddf97e.tar.gz
gentoo-2-5a553ed9d7eda22074979b57bf19f1904cddf97e.tar.bz2
gentoo-2-5a553ed9d7eda22074979b57bf19f1904cddf97e.zip
Version bump to 52.1; fixes bug #497930, proxied commit for Arfrever Frehtes Taifersar Arahesis whom also found a fix for a failing test.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icu4j/ChangeLog14
-rw-r--r--dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-1.patch18
-rw-r--r--dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-2.patch95
-rw-r--r--dev-java/icu4j/icu4j-52.1.ebuild53
4 files changed, 177 insertions, 3 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index d37c5727998e..3fa9aff0db27 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-java/icu4j
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.60 2012/12/08 12:34:03 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.61 2014/01/12 20:28:02 tomwij Exp $
+
+*icu4j-52.1 (12 Jan 2014)
+
+ 12 Jan 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-1.patch,
+ +files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-2.patch,
+ +icu4j-52.1.ebuild:
+ Version bump to 52.1; fixes bug #497930, proxied commit for Arfrever Frehtes
+ Taifersar Arahesis whom also found a fix for a failing test.
08 Dec 2012; Agostino Sarubbo <ago@gentoo.org> icu4j-49.1.ebuild:
Stable for ppc64, wrt bug #428078
@@ -247,4 +256,3 @@
19 Sep 2004; Thomas Matthijs <axxo@gentoo.org> +metadata.xml,
+icu4j-3.0.ebuild:
initial import, ebuild created by me as a dep
-
diff --git a/dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-1.patch b/dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-1.patch
new file mode 100644
index 000000000000..64151008822f
--- /dev/null
+++ b/dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-1.patch
@@ -0,0 +1,18 @@
+Index: /icu4j/trunk/main/classes/core/src/com/ibm/icu/text/SimpleDateFormat.java
+===================================================================
+--- /icu4j/trunk/main/classes/core/src/com/ibm/icu/text/SimpleDateFormat.java (revision 34829)
++++ /icu4j/trunk/main/classes/core/src/com/ibm/icu/text/SimpleDateFormat.java (revision 34830)
+@@ -1,5 +1,5 @@
+ /*
+ *******************************************************************************
+- * Copyright (C) 1996-2013, International Business Machines Corporation and *
++ * Copyright (C) 1996-2014, International Business Machines Corporation and *
+ * others. All Rights Reserved. *
+ *******************************************************************************
+@@ -2820,5 +2820,5 @@
+ if ( override != null && (override.compareTo("hebr") == 0 || override.indexOf("y=hebr") >= 0) && value < 1000 ) {
+ value += HEBREW_CAL_CUR_MILLENIUM_START_YEAR;
+- } else if (count == 2 && (pos.getIndex() - start) == 2 && !isChineseCalendar
++ } else if (count == 2 && (pos.getIndex() - start) == 2 && !isChineseCalendar && !cal.getType().equals("japanese")
+ && UCharacter.isDigit(text.charAt(start))
+ && UCharacter.isDigit(text.charAt(start+1)))
diff --git a/dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-2.patch b/dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-2.patch
new file mode 100644
index 000000000000..dd47da77ad68
--- /dev/null
+++ b/dev-java/icu4j/files/icu4j-52.1-fix-test-DataDrivenFormat-ConsistentPivot-2.patch
@@ -0,0 +1,95 @@
+Index: /icu4j/trunk/main/classes/core/src/com/ibm/icu/text/SimpleDateFormat.java
+===================================================================
+--- /icu4j/trunk/main/classes/core/src/com/ibm/icu/text/SimpleDateFormat.java (revision 34867)
++++ /icu4j/trunk/main/classes/core/src/com/ibm/icu/text/SimpleDateFormat.java (revision 34868)
+@@ -2820,5 +2820,5 @@
+ if ( override != null && (override.compareTo("hebr") == 0 || override.indexOf("y=hebr") >= 0) && value < 1000 ) {
+ value += HEBREW_CAL_CUR_MILLENIUM_START_YEAR;
+- } else if (count == 2 && (pos.getIndex() - start) == 2 && !isChineseCalendar && !cal.getType().equals("japanese")
++ } else if (count == 2 && (pos.getIndex() - start) == 2 && cal.haveDefaultCentury()
+ && UCharacter.isDigit(text.charAt(start))
+ && UCharacter.isDigit(text.charAt(start+1)))
+Index: /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/JapaneseCalendar.java
+===================================================================
+--- /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/JapaneseCalendar.java (revision 34867)
++++ /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/JapaneseCalendar.java (revision 34868)
+@@ -1,5 +1,5 @@
+ /*
+ *******************************************************************************
+- * Copyright (C) 1996-2010,2012, International Business Machines Corporation and *
++ * Copyright (C) 1996-2014, International Business Machines Corporation and *
+ * others. All Rights Reserved. *
+ *******************************************************************************
+@@ -639,4 +639,13 @@
+ /**
+ * {@inheritDoc}
++ * @internal
++ * @deprecated This API is ICU internal only.
++ */
++ public boolean haveDefaultCentury() {
++ return false;
++ }
++
++ /**
++ * {@inheritDoc}
+ * @stable ICU 4.0
+ */
+@@ -662,3 +671,4 @@
+ return super.getActualMaximum(field);
+ }
++
+ }
+Index: /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/Calendar.java
+===================================================================
+--- /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/Calendar.java (revision 34867)
++++ /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/Calendar.java (revision 34868)
+@@ -1,4 +1,4 @@
+ /*
+-* Copyright (C) 1996-2013, International Business Machines
++* Copyright (C) 1996-2014, International Business Machines
+ * Corporation and others. All Rights Reserved.
+ */
+@@ -6081,4 +6081,19 @@
+ }
+
++ /**
++ * Returns if two digit representation of year in this calendar type
++ * customarily implies a default century (i.e. 03 -> 2003).
++ * The default implementation returns <code>true</code>. A subclass may
++ * return <code>false</code> if such practice is not applicable (for example,
++ * Chinese calendar and Japanese calendar).
++ *
++ * @return <code>true<code> if this calendar has a default century.
++ * @internal
++ * @deprecated This API is ICU internal only.
++ */
++ public boolean haveDefaultCentury() {
++ return true;
++ }
++
+ // -------- BEGIN ULocale boilerplate --------
+
+Index: /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/ChineseCalendar.java
+===================================================================
+--- /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/ChineseCalendar.java (revision 34867)
++++ /icu4j/trunk/main/classes/core/src/com/ibm/icu/util/ChineseCalendar.java (revision 34868)
+@@ -1,4 +1,4 @@
+ /*********************************************************************
+- * Copyright (C) 2000-2012, International Business Machines
++ * Copyright (C) 2000-2014, International Business Machines
+ * Corporation and others. All Rights Reserved.
+ *********************************************************************
+@@ -1019,4 +1019,13 @@
+
+ /**
++ * {@inheritDoc}
++ * @internal
++ * @deprecated This API is ICU internal only.
++ */
++ public boolean haveDefaultCentury() {
++ return false;
++ }
++
++ /**
+ * Override readObject.
+ */
diff --git a/dev-java/icu4j/icu4j-52.1.ebuild b/dev-java/icu4j/icu4j-52.1.ebuild
new file mode 100644
index 000000000000..d462791f14b8
--- /dev/null
+++ b/dev-java/icu4j/icu4j-52.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-52.1.ebuild,v 1.1 2014/01/12 20:28:02 tomwij Exp $
+
+EAPI="5"
+
+# testdata.jar, icudata.jar and icutzdata.jar do not contain *.class files
+# but *.res files. These *.res data files are needed to build the final jar.
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support."
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${PV//./_}.tgz"
+
+LICENSE="icu"
+SLOT="52"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# Beware of jdk version dependant code #361593
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+JAVA_PKG_BSFIX_NAME+=" common-targets.xml"
+
+EANT_DOC_TARGET="docs"
+EANT_TEST_TARGET="check"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-test-DataDrivenFormat-ConsistentPivot-1.patch
+ epatch "${FILESDIR}"/${P}-fix-test-DataDrivenFormat-ConsistentPivot-2.patch
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dojar ${PN}-charset.jar
+ java-pkg_dojar ${PN}-localespi.jar
+
+ dohtml readme.html
+
+ use doc && java-pkg_dojavadoc doc
+ use examples && java-pkg_doexamples demos samples
+ use source && java-pkg_dosrc main/classes/*/src/com
+}