summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-06-17 11:24:08 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-06-17 11:24:08 +0000
commit58a9c48ec1d2cc52399372d4f7e39b80a47e2adc (patch)
treea25858d4f38e94d2d987e639a3de2f86964b8902 /dev-java
parentNM: Cleanup superseded ebuilds. (diff)
downloadgentoo-2-58a9c48ec1d2cc52399372d4f7e39b80a47e2adc.tar.gz
gentoo-2-58a9c48ec1d2cc52399372d4f7e39b80a47e2adc.tar.bz2
gentoo-2-58a9c48ec1d2cc52399372d4f7e39b80a47e2adc.zip
NM: Cleanup superseded ebuilds.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/nailgun/ChangeLog8
-rw-r--r--dev-java/nailgun/files/0.7.1-Makefile.patch13
-rw-r--r--dev-java/nailgun/nailgun-0.7.1.ebuild67
3 files changed, 6 insertions, 82 deletions
diff --git a/dev-java/nailgun/ChangeLog b/dev-java/nailgun/ChangeLog
index 4081bfda098d..879af27e15a5 100644
--- a/dev-java/nailgun/ChangeLog
+++ b/dev-java/nailgun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/nailgun
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/nailgun/ChangeLog,v 1.12 2012/12/16 14:51:37 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nailgun/ChangeLog,v 1.13 2014/06/17 11:24:08 mrueg Exp $
+
+ 17 Jun 2014; Manuel Rüger <mrueg@gentoo.org> -files/0.7.1-Makefile.patch,
+ -nailgun-0.7.1.ebuild:
+ NM: Cleanup superseded ebuilds.
16 Dec 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due retirement, #169737
diff --git a/dev-java/nailgun/files/0.7.1-Makefile.patch b/dev-java/nailgun/files/0.7.1-Makefile.patch
deleted file mode 100644
index fe489d46ede9..000000000000
--- a/dev-java/nailgun/files/0.7.1-Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig 2009-08-07 23:44:55.000000000 +1200
-+++ Makefile 2009-08-07 23:45:43.000000000 +1200
-@@ -5,9 +5,8 @@
- #
- # Marty Lamb
-
--CC=gcc
- WIN32_CC=/usr/local/mingw32/bin/mingw32-gcc
--CFLAGS=-Wall -pedantic -s -O3
-+CFLAGS+=-Wall
-
- ng: src/c/ng.c
- @echo "Building ng client. To build a Windows binary, type 'make ng.exe'"
diff --git a/dev-java/nailgun/nailgun-0.7.1.ebuild b/dev-java/nailgun/nailgun-0.7.1.ebuild
deleted file mode 100644
index 59c07bd3d869..000000000000
--- a/dev-java/nailgun/nailgun-0.7.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/nailgun/nailgun-0.7.1.ebuild,v 1.10 2011/08/05 16:08:14 ulm Exp $
-
-EAPI="2"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="a client, protocol, and server for running Java apps without incurring the JVM startup overhead"
-HOMEPAGE="http://martiansoftware.com/nailgun/index.html"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="test"
-
-RDEPEND=">=virtual/jre-1.4
- !app-editors/ng"
-DEPEND=">=virtual/jdk-1.4
- dev-java/java-getopt:1
- dev-java/bcel:0
- dev-java/jakarta-oro:2.0
- dev-java/log4j:0
- app-arch/unzip
- dev-java/junit:0
- test? (
- dev-java/ant-junit:0
- )"
-
-#need jcoverage
-RESTRICT="test"
-
-java_prepare() {
- rm -vf ng* beansh
- find . -iname '*.jar' -delete
-
- epatch "${FILESDIR}/${PV}-Makefile.patch"
-
- sed -i '/<arg line="ng.exe/d' build.xml || die
- sed -i 's/depends="test"/depends="compile"/' build.xml || die
-
- java-pkg_jar-from --into tools/lib --build-only java-getopt-1 \
- gnu.getopt.jar java-getopt-1.0.10.jar
- java-pkg_jar-from --into tools/lib --build-only junit junit.jar
- java-pkg_jar-from --into tools/lib --build-only bcel bcel.jar \
- bcel-5.1.jar
- java-pkg_jar-from --into tools/lib --build-only jakarta-oro-2.0 \
- jakarta-oro.jar jakarta-oro-2.0.8.jar
- java-pkg_jar-from --into tools/lib --build-only log4j log4j.jar \
- log4j-1.2.8.jar
-}
-
-src_test() {
- WANT_TASKS="ant-junit" eant test
-}
-
-src_install() {
- dobin ng
- # Should we have a dolauncher?
-
- java-pkg_newjar "dist/${P}.jar"
- use doc && java-pkg_dojavadoc docs/api
- use source && java-pkg_dosrc src/java/prod/*
-}