summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2013-09-25 17:40:20 +0000
committerJohann Schmitz <ercpe@gentoo.org>2013-09-25 17:40:20 +0000
commit489b38a778ce3acfe596fd22d0ce734ea2d1f232 (patch)
tree1f6002f037c7c543b0cc01111c63acb0f27889e1 /dev-java
parentVersion bump fixes bug 485696 and includes patch from bug 472554. pgadmin3-de... (diff)
downloadgentoo-2-489b38a778ce3acfe596fd22d0ce734ea2d1f232.tar.gz
gentoo-2-489b38a778ce3acfe596fd22d0ce734ea2d1f232.tar.bz2
gentoo-2-489b38a778ce3acfe596fd22d0ce734ea2d1f232.zip
Ebuild for classmate-0.9.0 - java introspection library
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/classmate/ChangeLog9
-rw-r--r--dev-java/classmate/classmate-0.9.0.ebuild43
-rw-r--r--dev-java/classmate/metadata.xml9
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/classmate/ChangeLog b/dev-java/classmate/ChangeLog
new file mode 100644
index 000000000000..8aaea13a9004
--- /dev/null
+++ b/dev-java/classmate/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/classmate
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/classmate/ChangeLog,v 1.1 2013/09/25 17:40:20 ercpe Exp $
+
+*classmate-0.9.0 (25 Sep 2013)
+
+ 25 Sep 2013; Johann Schmitz <ercpe@gentoo.org> +classmate-0.9.0.ebuild,
+ +metadata.xml:
+ Ebuild for classmate-0.9.0 - java introspection library
diff --git a/dev-java/classmate/classmate-0.9.0.ebuild b/dev-java/classmate/classmate-0.9.0.ebuild
new file mode 100644
index 000000000000..b46d7848682b
--- /dev/null
+++ b/dev-java/classmate/classmate-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/classmate/classmate-0.9.0.ebuild,v 1.1 2013/09/25 17:40:20 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="Library for introspecting generic type information of types, member/static methods, fields"
+HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
+SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ rm pom.xml || die
+}
+
+src_test() {
+ testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
+
+ mkdir target/tests || die
+ ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
+
+ tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}
diff --git a/dev-java/classmate/metadata.xml b/dev-java/classmate/metadata.xml
new file mode 100644
index 000000000000..a983ca93370a
--- /dev/null
+++ b/dev-java/classmate/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">cowtowncoder/java-classmate</remote-id>
+ </upstream>
+</pkgmetadata>
+