summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-04-13 22:19:12 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-04-13 22:19:12 +0000
commit2d71b5a7240f0dffd5ec803407692777a8dc38d0 (patch)
tree5b4c93cdbe686c568236294b1c61c02949e9cf87 /dev-java
parentAdd support for USE=vanilla. (diff)
downloadgentoo-2-2d71b5a7240f0dffd5ec803407692777a8dc38d0.tar.gz
gentoo-2-2d71b5a7240f0dffd5ec803407692777a8dc38d0.tar.bz2
gentoo-2-2d71b5a7240f0dffd5ec803407692777a8dc38d0.zip
Version bump.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/joda-time/ChangeLog8
-rw-r--r--dev-java/joda-time/joda-time-1.5.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-java/joda-time/ChangeLog b/dev-java/joda-time/ChangeLog
index 5eb601aa5e4a..eb7048d1f25a 100644
--- a/dev-java/joda-time/ChangeLog
+++ b/dev-java/joda-time/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/joda-time
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.35 2008/03/30 17:03:41 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/ChangeLog,v 1.36 2008/04/13 22:19:12 betelgeuse Exp $
+
+*joda-time-1.5.2 (13 Apr 2008)
+
+ 13 Apr 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +joda-time-1.5.2.ebuild:
+ Version bump.
30 Mar 2008; Markus Rothe <corsair@gentoo.org> joda-time-1.5.1.ebuild:
Added ~ppc64
diff --git a/dev-java/joda-time/joda-time-1.5.2.ebuild b/dev-java/joda-time/joda-time-1.5.2.ebuild
new file mode 100644
index 000000000000..8084fe05d854
--- /dev/null
+++ b/dev-java/joda-time/joda-time-1.5.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/joda-time-1.5.2.ebuild,v 1.1 2008/04/13 22:19:12 betelgeuse Exp $
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P}-src"
+
+DESCRIPTION="A quality open-source replacement for the Java Date and Time classes."
+HOMEPAGE="http://joda-time.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEP="elibc_glibc? ( >=sys-libs/timezone-data-2007h ) "
+
+DEPEND="
+ >=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -v *.jar || die
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1855430&group_id=97367&atid=617889
+ epatch "${FILESDIR}/1.5.1-ecj.patch"
+}
+
+# chokes on static inner class making instance of non-static inner class
+EANT_FILTER_COMPILER="jikes"
+# little trick so it doesn't try to download junit
+EANT_EXTRA_ARGS="-Djunit.ant=1 -Djunit.present=1"
+
+src_test() {
+ if has_version "<sys-libs/timezone-data-2007c"; then
+ ewarn "Tests are known to fail with older versions of"
+ ewarn "sys-libs/timezone-data. Please update to the latest stable"
+ ewarn "version. We don't force it because not all libc"
+ ewarn "implementations use that package. See bugzilla for details:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=170189"
+ fi
+
+ ANT_TASKS="ant-junit" eant -Djunit.jar="$(java-pkg_getjars junit)" test
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar
+
+ dodoc LICENSE.txt NOTICE.txt RELEASE-NOTES.txt ToDo.txt || die
+ use doc && java-pkg_dojavadoc build/docs
+ use examples && java-pkg_doexamples src/example
+ use source && java-pkg_dosrc src/java/org
+}