summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-06-01 21:56:22 +0000
committerVlastimil Babka <caster@gentoo.org>2009-06-01 21:56:22 +0000
commit09ddedb8c7d3183f45aee9177260afbd2de2fe7b (patch)
tree880b7e211335cf9e74ed7d30562f136ad79df3eb /dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild
parentVersion bump. Updated to telepathy-spec 0.17.25. With blessing from peper. (diff)
downloadgentoo-2-09ddedb8c7d3183f45aee9177260afbd2de2fe7b.tar.gz
gentoo-2-09ddedb8c7d3183f45aee9177260afbd2de2fe7b.tar.bz2
gentoo-2-09ddedb8c7d3183f45aee9177260afbd2de2fe7b.zip
Revbump so that the commons-lang slot change works properly, not causing bugs such as #272040.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild')
-rw-r--r--dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild b/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild
new file mode 100644
index 000000000000..2586c563b3e8
--- /dev/null
+++ b/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xsd2jibx/xsd2jibx-0.2a_beta-r2.ebuild,v 1.1 2009/06/01 21:56:22 caster Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+MY_PV="beta2a"
+
+DESCRIPTION="JiBX binding and code from schema generator"
+HOMEPAGE="http://jibx.sourceforge.net/xsd2jibx/"
+SRC_URI="mirror://sourceforge/jibx/${PN}-${MY_PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/commons-logging:0
+ dev-java/xpp3:0
+ dev-java/jaxme:0
+ dev-java/jibx:0
+ dev-java/commons-lang:2.1"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ cp "${FILESDIR}/build.xml" .
+ # patch from freemind authors, freemind won't build without it
+ # they sent upstream (that's how I found it) which said he's preparing
+ # complete rewrite. It only adds non-abstract functionality.
+ epatch "${FILESDIR}/${P}-freemind.patch"
+
+ cd "${S}/lib"
+ rm -v *.jar || die
+ java-pkg_jar-from commons-logging,xpp3,jaxme,jibx,commons-lang-2.1
+}
+
+EANT_ANT_TASKS="jibx"
+EANT_EXTRA_ARGS="-Djibxhome=/usr/share/jibx/"
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ dohtml -R docs/*
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc src/main/org
+}