summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-06-19 00:29:25 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-06-19 00:29:25 +0000
commit97f4578b7f14673eb778b3b026f0cd5dc0e3f1bf (patch)
treeaa59c113621101b49bc7148a035e758521dff0bd /dev-java/xom
parentNM: Cleanup superseded ebuilds. (diff)
downloadgentoo-2-97f4578b7f14673eb778b3b026f0cd5dc0e3f1bf.tar.gz
gentoo-2-97f4578b7f14673eb778b3b026f0cd5dc0e3f1bf.tar.bz2
gentoo-2-97f4578b7f14673eb778b3b026f0cd5dc0e3f1bf.zip
NM: Cleanup superseded ebuilds.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-java/xom')
-rw-r--r--dev-java/xom/ChangeLog5
-rw-r--r--dev-java/xom/xom-1.2.6-r1.ebuild78
2 files changed, 4 insertions, 79 deletions
diff --git a/dev-java/xom/ChangeLog b/dev-java/xom/ChangeLog
index 5189fd686105..f300e2a346ec 100644
--- a/dev-java/xom/ChangeLog
+++ b/dev-java/xom/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/xom
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/ChangeLog,v 1.73 2014/04/20 11:35:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/ChangeLog,v 1.74 2014/06/19 00:29:25 mrueg Exp $
+
+ 19 Jun 2014; Manuel Rüger <mrueg@gentoo.org> -xom-1.2.6-r1.ebuild:
+ NM: Cleanup superseded ebuilds.
20 Apr 2014; Agostino Sarubbo <ago@gentoo.org> xom-1.2.10.ebuild:
Stable for ppc64, wrt bug #492020
diff --git a/dev-java/xom/xom-1.2.6-r1.ebuild b/dev-java/xom/xom-1.2.6-r1.ebuild
deleted file mode 100644
index 8583bec5485d..000000000000
--- a/dev-java/xom/xom-1.2.6-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.2.6-r1.ebuild,v 1.6 2013/02/05 07:28:53 zerochaos Exp $
-
-EAPI="4"
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2
-
-JAXEN_V="1.1.3"
-JAXEN_P="jaxen-${JAXEN_V}"
-
-DESCRIPTION="A new XML object model."
-HOMEPAGE="http://cafeconleche.org/XOM/index.html"
-SRC_URI="http://cafeconleche.org/XOM/${P}.tar.gz
- http://dist.codehaus.org/jaxen/distributions/${JAXEN_P}-src.tar.gz"
-# Bundled jaxen as its moved under XOM's namespace
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-COMMON_DEPEND="dev-java/xerces:2
- dev-java/xml-commons-external:1.3
- examples? ( java-virtuals/servlet-api:2.4 )"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPEND}"
-DEPEND=">=virtual/jdk-1.4
- dev-java/jarjar:1
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}/XOM"
-
-# Test require network access to pass
-# They need a redirected http document on public web
-RESTRICT="test"
-
-java_prepare() {
- epatch "${FILESDIR}/${P}.patch"
- epatch "${FILESDIR}/${PN}-strip-fallback-parser.patch" #399119
-
- # Delete test files as they aren't installed
- rm -vr src/nu/xom/tests || die
-
- # Delete bundled jars
- rm -v *.jar lib/*.jar || die
-
- # Delete bundled classes
- find . -name "*.class" -delete -print || die
-
- # Move bundled jaxen to where the build.xml expects it
- mv "${WORKDIR}"/${JAXEN_P}/ lib/ || die
-
- java-pkg_jar-from --into lib/ xml-commons-external-1.3
- java-pkg_jar-from --into lib/ xerces-2
- java-pkg_jar-from --build-only --into lib/ jarjar-1
- # tagsoup is only needed to run betterdoc but we use the pregenerated ones
-}
-
-src_compile() {
- local ant_flags="-Ddebug=off"
- use examples && ant_flags="${ant_flags} -Dservlet.jar=$(java-pkg_getjar servlet-api-2.4 servlet-api.jar)"
-
- ANT_TASKS="jarjar-1" eant jar ${ant_flags}\
- $(use examples && echo samples)
-}
-
-src_install() {
- java-pkg_newjar build/${P}.jar ${PN}.jar
- use examples && java-pkg_dojar build/xom-samples.jar
- dodoc Todo.txt
-
- use doc && java-pkg_dojavadoc apidocs/
- use source && java-pkg_dosrc src/*
- use examples && java-pkg_doexamples --subdir nu/xom/samples src/nu/xom/samples
-}