summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2003-12-02 04:18:44 +0000
committerAdrian Almenar <strider@gentoo.org>2003-12-02 04:18:44 +0000
commitfb7c4081950000b6bca6b5c186386c13450e3d1b (patch)
tree1e612df5d9f3346d8295f7683a0cea0df19de085 /dev-java/xerces/xerces-2.6.0.ebuild
parentNew Upstream Version (diff)
downloadgentoo-2-fb7c4081950000b6bca6b5c186386c13450e3d1b.tar.gz
gentoo-2-fb7c4081950000b6bca6b5c186386c13450e3d1b.tar.bz2
gentoo-2-fb7c4081950000b6bca6b5c186386c13450e3d1b.zip
New Upstream Version
Diffstat (limited to 'dev-java/xerces/xerces-2.6.0.ebuild')
-rw-r--r--dev-java/xerces/xerces-2.6.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/xerces/xerces-2.6.0.ebuild b/dev-java/xerces/xerces-2.6.0.ebuild
new file mode 100644
index 000000000000..8c044f297bc9
--- /dev/null
+++ b/dev-java/xerces/xerces-2.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xerces/xerces-2.6.0.ebuild,v 1.1 2003/12/02 04:18:31 strider Exp $
+
+inherit java-pkg eutils
+
+S=${WORKDIR}/xerces-${PV//./_}
+DESCRIPTION="The next generation of high performance, fully compliant XML parsers in the Apache Xerces family"
+HOMEPAGE="http://xml.apache.org/xerces2-j/index.html"
+SRC_URI="mirror://apache/xml/xerces-j/Xerces-J-src.${PV}.tar.gz
+ mirror://apache/xml/xerces-j/Xerces-J-tools.${PV}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="doc"
+
+DEPEND=">=dev-java/ant-1.5.2"
+RDEPEND=">=virtual/jdk-1.3"
+RESTRICT="nomirror"
+
+src_unpack() {
+ unpack ${A}
+ mv tools ${S}
+}
+
+src_compile() {
+ if [ -n "`use doc`" ] ; then
+ sh build.sh jars sampjar javadocs || die "Compile failed."
+ else
+ sh build.sh jars sampjar || die "Compile failed."
+ fi
+}
+
+src_install() {
+ java-pkg_dojar build/x*.jar
+ dodoc TODO STATUS README LICENSE ISSUES
+ dohtml Readme.html
+
+ if [ -n "`use doc`" ] ; then
+ dodir /usr/share/doc/${P}
+ cp -a samples ${D}/usr/share/doc/${P}
+ dohtml -r build/docs/javadocs
+ fi
+}