summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-29 16:00:43 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-29 16:00:43 +0000
commit2d4db582dc05b74c71ac3559697ccd8442a91be3 (patch)
treede029652a8932ac19f44e008e4dca5476310df84 /dev-java/velocity
parentVersion bumped. Marked 20040411 stable on x86 and ppc; bug #87072. (diff)
downloadgentoo-2-2d4db582dc05b74c71ac3559697ccd8442a91be3.tar.gz
gentoo-2-2d4db582dc05b74c71ac3559697ccd8442a91be3.tar.bz2
gentoo-2-2d4db582dc05b74c71ac3559697ccd8442a91be3.zip
moved from dev-java/oro to dev-java/jakarta-oro dependency. see #71337.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/velocity')
-rw-r--r--dev-java/velocity/ChangeLog9
-rw-r--r--dev-java/velocity/files/digest-velocity-1.4-r11
-rw-r--r--dev-java/velocity/velocity-1.4-r1.ebuild48
-rw-r--r--dev-java/velocity/velocity-1.4.ebuild4
4 files changed, 58 insertions, 4 deletions
diff --git a/dev-java/velocity/ChangeLog b/dev-java/velocity/ChangeLog
index bc8baf90e2fa..68f3ad63387a 100644
--- a/dev-java/velocity/ChangeLog
+++ b/dev-java/velocity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/velocity
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.14 2004/10/16 17:39:18 axxo Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.15 2005/03/29 16:00:43 luckyduck Exp $
+
+*velocity-1.4-r1 (29 Mar 2005)
+
+ 29 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> +velocity-1.4-r1.ebuild:
+ moved from dev-java/oro to dev-java/jakarta-oro dependency. see #71337.
16 Oct 2004; Thomas Matthijs <axxo@gentoo.org> velocity-1.4.ebuild:
use java-pkg_dohtml instead of dohtml to also install the package-list in
diff --git a/dev-java/velocity/files/digest-velocity-1.4-r1 b/dev-java/velocity/files/digest-velocity-1.4-r1
new file mode 100644
index 000000000000..ccc2e9c9c5dd
--- /dev/null
+++ b/dev-java/velocity/files/digest-velocity-1.4-r1
@@ -0,0 +1 @@
+MD5 f280fee7ddb5eac5b354f6dea39a2f51 velocity-1.4.tar.gz 4566056
diff --git a/dev-java/velocity/velocity-1.4-r1.ebuild b/dev-java/velocity/velocity-1.4-r1.ebuild
new file mode 100644
index 000000000000..950a23413d73
--- /dev/null
+++ b/dev-java/velocity/velocity-1.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4-r1.ebuild,v 1.1 2005/03/29 16:00:43 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="A Java-based template engine that allows easy creation/rendering of documents that format and present data."
+HOMEPAGE="http://jakarta.apache.org/velocity/"
+SRC_URI="mirror://apache/jakarta/velocity/binaries/velocity-${PV}/velocity-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc j2ee jikes junit"
+
+DEPEND=">=virtual/jdk-1.3.1"
+RDEPEND=">=virtual/jdk-1.3.1
+ >=dev-java/ant-1.5.1
+ >=dev-java/avalon-logkit-bin-1.2
+ =dev-java/jakarta-oro-2.0*
+ j2ee? ( =dev-java/sun-j2ee-1.3.1* )
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+src_compile () {
+ cd ${S}/build
+ local antflags
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use junit && antflags="${antflags} test"
+ use doc && antflags="${antflags} javadocs"
+ if use j2ee ; then
+ cp /opt/sun-j2ee-1.3.1/lib/j2ee.jar ${S}/build/lib
+ ant ${antflags} jar-J2EE || die "Java compile failed."
+ else
+ ant ${antflags} jar || die "Java compile failed"
+ fi
+}
+
+
+src_install () {
+ cd ${S}
+ if use j2ee ; then
+ java-pkg_dojar bin/${PN}-J2EE-${PV}.jar
+ else
+ java-pkg_dojar bin/${PN}-${PV}.jar
+ fi
+ dodoc LICENSE NOTICE README.txt
+ use doc && java-pkg_dohtml -r docs/*
+}
diff --git a/dev-java/velocity/velocity-1.4.ebuild b/dev-java/velocity/velocity-1.4.ebuild
index 2ff0e5c2fb28..5552cb2dc626 100644
--- a/dev-java/velocity/velocity-1.4.ebuild
+++ b/dev-java/velocity/velocity-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4.ebuild,v 1.6 2004/10/16 17:39:18 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4.ebuild,v 1.7 2005/03/29 16:00:43 luckyduck Exp $
inherit java-pkg