summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-15 14:39:20 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-15 14:39:20 +0000
commit47ead242aafdf7d5743403e9655d9b0b6e5ed877 (patch)
tree04999b81ebebf959c4a555eeca5bd4c80096051b /dev-java/tagunit
parentfix source loc (diff)
downloadgentoo-2-47ead242aafdf7d5743403e9655d9b0b6e5ed877.tar.gz
gentoo-2-47ead242aafdf7d5743403e9655d9b0b6e5ed877.tar.bz2
gentoo-2-47ead242aafdf7d5743403e9655d9b0b6e5ed877.zip
dep/style fixes
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/tagunit')
-rw-r--r--dev-java/tagunit/tagunit-1.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-java/tagunit/tagunit-1.0.1.ebuild b/dev-java/tagunit/tagunit-1.0.1.ebuild
index 50dd08628838..bac15aa5c2b2 100644
--- a/dev-java/tagunit/tagunit-1.0.1.ebuild
+++ b/dev-java/tagunit/tagunit-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1.ebuild,v 1.10 2005/07/08 10:52:58 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1.ebuild,v 1.11 2005/07/15 14:39:20 axxo Exp $
inherit java-pkg
@@ -13,13 +13,16 @@ SLOT="0"
KEYWORDS="x86 amd64 ~ppc"
IUSE="doc jikes source"
+RDEPEND=">=virtual/jre-1.3
+ =dev-java/servletapi-2.4*"
+
DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}
app-arch/unzip
>=dev-java/ant-core-1.6
jikes? ( >=dev-java/jikes-1.17 )
source? ( app-arch/zip )"
-RDEPEND=">=virtual/jdk-1.3
- =dev-java/servletapi-2.4*"
+
S="${WORKDIR}/${P}-src/tagunit-core"
src_compile() {
@@ -27,7 +30,7 @@ src_compile() {
mkdir ../lib
local antflags="build"
- antflags="${antflags} -lib `java-config --classpath=servletapi-2.4`"
+ antflags="${antflags} -lib $(java-pkg_getjars servletapi-2.4)"
use doc && antflags="${antflags} javadoc"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "compilation failed"