summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-08-18 10:12:17 +0000
committerVlastimil Babka <caster@gentoo.org>2009-08-18 10:12:17 +0000
commit91aac85929ac1738e9ca482134b54d6195594176 (patch)
treeda0a442a1db12c529c5601d3ef28a3a71bc4f2f8 /dev-java/sun-jre-bin
parentVersion bump, fixes JDWP threadid problems. Remove old. (diff)
downloadgentoo-2-91aac85929ac1738e9ca482134b54d6195594176.tar.gz
gentoo-2-91aac85929ac1738e9ca482134b54d6195594176.tar.bz2
gentoo-2-91aac85929ac1738e9ca482134b54d6195594176.zip
Version bump, fixes JDWP threadid problems. Remove old.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog9
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild114
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.14.ebuild141
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.16.ebuild (renamed from dev-java/sun-jre-bin/sun-jre-bin-1.6.0.13.ebuild)4
4 files changed, 10 insertions, 258 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 401313f8d727..545bbc4dc5cd 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.157 2009/08/11 05:54:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.158 2009/08/18 10:12:17 caster Exp $
+
+*sun-jre-bin-1.6.0.16 (18 Aug 2009)
+
+ 18 Aug 2009; Vlastimil Babka <caster@gentoo.org>
+ -sun-jre-bin-1.5.0.19.ebuild, -sun-jre-bin-1.6.0.13.ebuild,
+ -sun-jre-bin-1.6.0.14.ebuild, +sun-jre-bin-1.6.0.16.ebuild:
+ Version bump, fixes JDWP threadid problems. Remove old.
11 Aug 2009; Markus Meier <maekke@gentoo.org> sun-jre-bin-1.5.0.20.ebuild,
sun-jre-bin-1.6.0.15.ebuild:
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild
deleted file mode 100644
index 1c6a614403d7..000000000000
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.19.ebuild,v 1.3 2009/08/02 13:11:45 maekke Exp $
-
-inherit pax-utils versionator eutils java-vm-2
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
-
-X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
-AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
-
-DESCRIPTION="Sun's Java SE Runtime Environment"
-HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
-SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
- amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
-SLOT="1.5"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64 x86"
-RESTRICT="strip"
-IUSE="X alsa nsplugin odbc"
-
-RDEPEND="sys-libs/glibc
- alsa? ( media-libs/alsa-lib )
- X? (
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXp
- x11-libs/libXtst
- x11-libs/libXt
- x11-libs/libX11
- )
- odbc? ( dev-db/unixODBC )"
-DEPEND=""
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}/construct.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- if use x86; then
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
- fi
-}
-
-src_install() {
- local dirs="bin lib man"
- # only X86 has the plugin and javaws
- use x86 && dirs="${dirs} javaws plugin"
- dodir /opt/${P}
-
- cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- if use x86 ; then
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- else
- eerror "No plugin available for amd64 arch"
- fi
- fi
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- # bug #56444
- insinto /opt/${P}/lib/
- newins "${FILESDIR}"/fontconfig.Gentoo.properties \
- fontconfig.properties || die
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- elog "The epoll-based implementation of SelectorProvider is not selected by"
- elog "default."
- elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
-}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.14.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.14.ebuild
deleted file mode 100644
index b20830432fd0..000000000000
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.14.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.14.ebuild,v 1.2 2009/07/01 09:34:36 fauli Exp $
-
-inherit versionator pax-utils eutils java-vm-2
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2)u${UPDATE}"
-
-SUFFIX=".bin"
-X86_AT="jdk-${MY_PV}-dlj-linux-i586${SUFFIX}"
-AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64${SUFFIX}"
-
-DESCRIPTION="Sun's Java SE Runtime Environment"
-HOMEPAGE="http://java.sun.com/javase/6/"
-URL_BASE="http://download.java.net/dlj/binaries"
-SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
- amd64? ( ${URL_BASE}/${AMD64_AT} )"
-SLOT="1.6"
-LICENSE="dlj-1.1"
-KEYWORDS="-* ~amd64 x86"
-RESTRICT="strip"
-IUSE="X alsa nsplugin odbc"
-
-RDEPEND="sys-libs/glibc
- x86? ( =virtual/libstdc++-3.3 )
- alsa? ( media-libs/alsa-lib )
- X? (
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXp
- x11-libs/libXtst
- amd64? ( x11-libs/libXt )
- x11-libs/libX11
- )
- odbc? ( dev-db/unixODBC )"
-DEPEND=""
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_x86="opt/${P}/lib/i386/client/libjvm.so
- opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so
- opt/${P}/lib/i386/server/libjvm.so"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}/construct-1.6.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- if use x86; then
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
- "${S}"/bin/java -server -Xshare:dump || die
- fi
-}
-
-src_install() {
- local dirs="bin lib man"
-
- # only X86 has the plugin and javaws
- use x86 && dirs="${dirs} javaws plugin"
- dodir /opt/${P}
-
- cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
- dodir /opt/${P}/share/
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- if use x86 ; then
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- install_mozilla_plugin /opt/${P}/lib/i386/libnpjp2.so plugin2
- else
- install_mozilla_plugin /opt/${P}/lib/amd64/libnpjp2.so
- fi
- fi
-
- # install control panel for Gnome/KDE
- if [[ -e "${D}/opt/${P}/plugin/desktop/sun_java.desktop" ]]; then
- sed -e "s/\(Name=Java\)/\1 Control Panel for Sun JRE ${SLOT}/" \
- -e "s#Exec=.*#Exec=/opt/${P}/bin/ControlPanel#" \
- -e "s#Icon=.*#Icon=/opt/${P}/plugin/desktop/sun_java.png#" \
- "${D}/opt/${P}/plugin/desktop/sun_java.desktop" > \
- "${T}/sun_jre-${SLOT}.desktop" || die
- domenu "${T}/sun_jre-${SLOT}.desktop" || die
- fi
-
- # bug #56444
- insinto /opt/${P}/lib/
- newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- if use x86 && use nsplugin; then
- elog
- elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
- elog "${VMHANDLE} and ${VMHANDLE}-plugin2 (the Next-Generation Plug-In) "
- ewarn "Note that the ${VMHANDLE}-plugin2 works only in Firefox 3!"
- elog "For more info see https://jdk6.dev.java.net/plugin2/"
- elog
- fi
-
- if use amd64 && use nsplugin; then
- elog
- elog "This version finally brings a browser plugin for amd64"
- elog "It is the so-called Next-Generation Plug-In (plugin2)"
- elog "Use eselect java-nsplugin to select it (${VMHANDLE})."
- ewarn "Note that it works only in Firefox 3 or newer browsers!"
- elog "For more info see https://jdk6.dev.java.net/plugin2/"
- elog
- fi
-
- elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
- elog "The epoll-based implementation of SelectorProvider is not selected by"
- elog "default."
- elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
-}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.13.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.16.ebuild
index 34d730028727..1861ee38e8d9 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.13.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.13.ebuild,v 1.3 2009/05/29 20:32:40 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.16.ebuild,v 1.1 2009/08/18 10:12:17 caster Exp $
inherit versionator pax-utils eutils java-vm-2
@@ -19,7 +19,7 @@ SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
amd64? ( ${URL_BASE}/${AMD64_AT} )"
SLOT="1.6"
LICENSE="dlj-1.1"
-KEYWORDS="-* amd64 x86"
+KEYWORDS="-* ~amd64 ~x86"
RESTRICT="strip"
IUSE="X alsa nsplugin odbc"