summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-12 19:33:15 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-12 19:33:15 +0000
commitb8c903f59ce0c70f360d03ebe63487b2fa67d9e3 (patch)
tree0f8fede5bf5d71af568dc14701f71e1c98fbd067 /dev-java/soap/soap-2.3.1.ebuild
parentAdd ~alpha keyword, bug 63724. (diff)
downloadgentoo-2-b8c903f59ce0c70f360d03ebe63487b2fa67d9e3.tar.gz
gentoo-2-b8c903f59ce0c70f360d03ebe63487b2fa67d9e3.tar.bz2
gentoo-2-b8c903f59ce0c70f360d03ebe63487b2fa67d9e3.zip
new ebuild, added as dependency of dev-java/jmeter, created by me
Diffstat (limited to 'dev-java/soap/soap-2.3.1.ebuild')
-rw-r--r--dev-java/soap/soap-2.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/soap/soap-2.3.1.ebuild b/dev-java/soap/soap-2.3.1.ebuild
new file mode 100644
index 000000000000..ed553c16c4bc
--- /dev/null
+++ b/dev-java/soap/soap-2.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/soap/soap-2.3.1.ebuild,v 1.1 2004/09/12 19:32:36 axxo Exp $
+
+inherit java-pkg
+DESCRIPTION="Apache SOAP (Simple Object Access Protocol) is an implementation of the SOAP submission to W3C"
+HOMEPAGE="http://ws.apache.org/soap/"
+SRC_URI="mirror://apache/ws/soap/version-${PV}/soap-src-${PV}.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND="virtual/jdk
+ dev-java/sun-javamail-bin
+ dev-java/sun-jaf-bin
+ ~dev-java/servletapi-2.4
+ >=dev-java/ant-1.6.0"
+RDEPEND="virtual/jre"
+
+MY_P=${P//./_}
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local antflags="compile"
+ use doc && antflags="${antflags} javadocs"
+ antflags="${antflags} -lib $(java-config -p xerces-2,sun-javamail-bin,sun-jaf-bin,servletapi-2.4)"
+ ant ${antflags} || die "compile failed"
+}
+
+src_install() {
+ java-pkg_dojar build/lib/soap.jar
+
+ use doc && dohtml -r build/javadocs/
+}