summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2014-03-23 18:59:59 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2014-03-23 18:59:59 +0000
commit9be4c811a61005b7fb7b9026c2373d7e5c84862a (patch)
treebf390bbbdce4fd3fd009f85ae6fa0a25069b0461 /dev-java/netbeans-websvccommon
parentnetbeans-webcommon: new ebuild for version 8.0 (diff)
downloadgentoo-2-9be4c811a61005b7fb7b9026c2373d7e5c84862a.tar.gz
gentoo-2-9be4c811a61005b7fb7b9026c2373d7e5c84862a.tar.bz2
gentoo-2-9be4c811a61005b7fb7b9026c2373d7e5c84862a.zip
netbeans-websvccommon: new ebuild for version 8.0
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/netbeans-websvccommon')
-rw-r--r--dev-java/netbeans-websvccommon/ChangeLog10
-rw-r--r--dev-java/netbeans-websvccommon/netbeans-websvccommon-8.0.ebuild94
2 files changed, 102 insertions, 2 deletions
diff --git a/dev-java/netbeans-websvccommon/ChangeLog b/dev-java/netbeans-websvccommon/ChangeLog
index db3721f0a629..41203075d318 100644
--- a/dev-java/netbeans-websvccommon/ChangeLog
+++ b/dev-java/netbeans-websvccommon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/netbeans-websvccommon
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-websvccommon/ChangeLog,v 1.19 2013/10/16 09:52:52 fordfrog Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-websvccommon/ChangeLog,v 1.20 2014/03/23 18:59:59 fordfrog Exp $
+
+*netbeans-websvccommon-8.0 (23 Mar 2014)
+
+ 23 Mar 2014; Miroslav Šulc <fordfrog@gentoo.org>
+ +netbeans-websvccommon-8.0.ebuild:
+ new ebuild for version 8.0
*netbeans-websvccommon-7.4 (16 Oct 2013)
diff --git a/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.0.ebuild b/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.0.ebuild
new file mode 100644
index 000000000000..34930a5505bf
--- /dev/null
+++ b/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-websvccommon/netbeans-websvccommon-8.0.ebuild,v 1.1 2014/03/23 18:59:59 fordfrog Exp $
+
+EAPI="4"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans Web Services Common Cluster"
+HOMEPAGE="http://netbeans.org/"
+SLOT="8.0"
+SOURCE_URL="http://download.netbeans.org/netbeans/8.0/final/zip/netbeans-8.0-201403101706-src.zip"
+SRC_URI="${SOURCE_URL}
+ http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.0-build.xml.patch.bz2"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-platform-${PV}
+ ~dev-java/netbeans-ide-${PV}"
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip
+ ${CDEPEND}
+ dev-java/javahelp:0"
+RDEPEND=">=virtual/jdk-1.7
+ ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.websvccommon -Dext.binaries.downloaded=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack $(basename ${SOURCE_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-8.0-build.xml.patch.bz2
+}
+
+src_prepare() {
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-8.0-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS80_PATCHES_DIR}" -a -d "${NETBEANS80_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS80_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+
+ einfo "Linking in other clusters..."
+ mkdir "${S}"/nbbuild/netbeans || die
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+ cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.platform.built
+
+ ln -s /usr/share/netbeans-ide-${SLOT} ide || die
+ cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.ide.built
+
+ popd >/dev/null || die
+
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ pushd nbbuild/netbeans/websvccommon >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+ grep -E "/websvccommon$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+ doins -r *
+
+ popd >/dev/null || die
+
+ dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/websvccommon
+}