summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2013-02-21 15:52:10 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2013-02-21 15:52:10 +0000
commit560ff2e092def92cfc5d2c69ae05212a03878538 (patch)
treea7e8a1b4dbaa51c56503322f0e382c5491238719 /dev-java/netbeans-php
parentdev-java/netbeans-nb: version bump (diff)
downloadgentoo-2-560ff2e092def92cfc5d2c69ae05212a03878538.tar.gz
gentoo-2-560ff2e092def92cfc5d2c69ae05212a03878538.tar.bz2
gentoo-2-560ff2e092def92cfc5d2c69ae05212a03878538.zip
dev-java/netbeans-php: version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/netbeans-php')
-rw-r--r--dev-java/netbeans-php/ChangeLog9
-rw-r--r--dev-java/netbeans-php/netbeans-php-7.3.ebuild123
2 files changed, 130 insertions, 2 deletions
diff --git a/dev-java/netbeans-php/ChangeLog b/dev-java/netbeans-php/ChangeLog
index 3e9964bb4f7a..85a1339f2bcf 100644
--- a/dev-java/netbeans-php/ChangeLog
+++ b/dev-java/netbeans-php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/netbeans-php
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-php/ChangeLog,v 1.17 2012/12/09 19:35:44 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-php/ChangeLog,v 1.18 2013/02/21 15:52:10 fordfrog Exp $
+
+*netbeans-php-7.3 (21 Feb 2013)
+
+ 21 Feb 2013; Miroslav Šulc <fordfrog@gentoo.org> +netbeans-php-7.3.ebuild:
+ version bump
09 Dec 2012; <ago@gentoo.org> netbeans-php-7.2.ebuild:
Stable for x86, wrt bug #441170
diff --git a/dev-java/netbeans-php/netbeans-php-7.3.ebuild b/dev-java/netbeans-php/netbeans-php-7.3.ebuild
new file mode 100644
index 000000000000..bd482c701691
--- /dev/null
+++ b/dev-java/netbeans-php/netbeans-php-7.3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-php/netbeans-php-7.3.ebuild,v 1.1 2013/02/21 15:52:10 fordfrog Exp $
+
+EAPI="4"
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans PHP Cluster"
+HOMEPAGE="http://netbeans.org/projects/php"
+SLOT="7.3"
+SOURCE_URL="http://download.netbeans.org/netbeans/7.3/final/zip/netbeans-7.3-201302132200-src.zip"
+SRC_URI="${SOURCE_URL}
+ http://dev.gentoo.org/~fordfrog/distfiles/netbeans-7.3-build.xml.patch.bz2
+ http://hg.netbeans.org/binaries/0702230EB3354A1687E4496D73A94F33A1E343BD-phpdocdesc.zip
+ http://hg.netbeans.org/binaries/2786575056B65CA8965B8D195E9FDE85BB895DD8-phpsigfiles.zip
+ http://hg.netbeans.org/binaries/3D6AF75EA20D715887DAF47A3F063864EF0814C1-predefined_vars.zip"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-ide-${PV}
+ ~dev-java/netbeans-platform-${PV}
+ ~dev-java/netbeans-webcommon-${PV}
+ ~dev-java/netbeans-websvccommon-${PV}
+ dev-java/javacup:0"
+DEPEND="virtual/jdk:1.6
+ app-arch/unzip
+ ${CDEPEND}
+ dev-java/javahelp:0"
+RDEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.php -Dext.binaries.downloaded=true -Dpermit.jdk7.builds=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack $(basename ${SOURCE_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-7.3-build.xml.patch.bz2
+
+ pushd "${S}" >/dev/null || die
+ ln -s "${DISTDIR}"/0702230EB3354A1687E4496D73A94F33A1E343BD-phpdocdesc.zip php.phpdoc.documentation/external/phpdocdesc.zip || die
+ ln -s "${DISTDIR}"/2786575056B65CA8965B8D195E9FDE85BB895DD8-phpsigfiles.zip php.project/external/phpsigfiles.zip || die
+ ln -s "${DISTDIR}"/3D6AF75EA20D715887DAF47A3F063864EF0814C1-predefined_vars.zip php.editor/external/predefined_vars.zip || die
+ popd >/dev/null || die
+}
+
+src_prepare() {
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-7.3-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS73_PATCHES_DIR}" -a -d "${NETBEANS73_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS73_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+ java-pkg_jar-from --into libs.javacup/external javacup javacup.jar java-cup-11a.jar
+
+ einfo "Linking in other clusters..."
+ mkdir "${S}"/nbbuild/netbeans || die
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ ln -s /usr/share/netbeans-ide-${SLOT} ide || die
+ cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.ide.built
+
+ ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+ cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.platform.built
+
+ ln -s /usr/share/netbeans-webcommon-${SLOT} webcommon || die
+ cat /usr/share/netbeans-webcommon-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.webcommon.built
+
+ ln -s /usr/share/netbeans-websvccommon-${SLOT} websvccommon || die
+ cat /usr/share/netbeans-websvccommon-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.websvccommon.built
+
+ popd >/dev/null || die
+
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ pushd nbbuild/netbeans/php >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+
+ grep -E "/php$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+
+ doins -r *
+
+ popd >/dev/null || die
+
+ local instdir=${INSTALL_DIR}/modules/ext
+ pushd "${D}"/${instdir} >/dev/null || die
+ rm java-cup-11a.jar && dosym /usr/share/javacup/lib/javacup.jar ${instdir}/java-cup-11a.jar || die
+ popd >/dev/null || die
+
+ dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/php
+}