summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-10-28 23:40:06 +0000
committerVlastimil Babka <caster@gentoo.org>2006-10-28 23:40:06 +0000
commitc55b026c5264e54e705fbb2e1f774982cd709877 (patch)
tree12a15536809d96dee9b9eafba6fc764c7d459d65 /dev-java/microba/microba-0.4.3.ebuild
parentRemove sse useflag, see bug #152540. (diff)
downloadgentoo-2-c55b026c5264e54e705fbb2e1f774982cd709877.tar.gz
gentoo-2-c55b026c5264e54e705fbb2e1f774982cd709877.tar.bz2
gentoo-2-c55b026c5264e54e705fbb2e1f774982cd709877.zip
Initial ebuild, based on contributed ebuild from Christian Faulhammer <opfer@gentoo.org> as jabref dependency in bug #122085.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'dev-java/microba/microba-0.4.3.ebuild')
-rw-r--r--dev-java/microba/microba-0.4.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/microba/microba-0.4.3.ebuild b/dev-java/microba/microba-0.4.3.ebuild
new file mode 100644
index 000000000000..70b4ab530af0
--- /dev/null
+++ b/dev-java/microba/microba-0.4.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/microba/microba-0.4.3.ebuild,v 1.1 2006/10/28 23:40:06 caster Exp $
+
+# does not need java-ant-2, source and target is already set to 1.4
+inherit java-pkg-2
+
+DESCRIPTION="Swing components for date operations and palettes"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.zip"
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+
+COMMON_DEPEND=">=dev-java/jgraph-5.9.2"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ app-arch/unzip
+ source? ( app-arch/zip )
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+
+IUSE="doc source"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unzip -qq "redist/${P}-src.zip"
+
+ rm lib-compiletime/*.jar
+ rm redist/*
+ # do not delete stuff after it's zipped
+ sed -i -e "/<delete/d" build.xml
+
+ cd lib-compiletime
+ java-pkg_jar-from jgraph jgraph.jar
+}
+
+src_compile() {
+ eant bin_release $(use_doc doc_release)
+}
+src_install() {
+ java-pkg_newjar redist/${P}-bin.jar
+ dodoc *.txt
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/com
+} \ No newline at end of file