summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-06-05 09:30:15 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-06-05 09:30:15 +0000
commit134b8b50d88866b9125e931ab98241d9c7dea84c (patch)
treee9c205d3a9e98766db46ca37fe878bf064a60949 /dev-java/jss
parentStable for x86, wrt bug #472350 (diff)
downloadgentoo-2-134b8b50d88866b9125e931ab98241d9c7dea84c.tar.gz
gentoo-2-134b8b50d88866b9125e931ab98241d9c7dea84c.tar.bz2
gentoo-2-134b8b50d88866b9125e931ab98241d9c7dea84c.zip
Revision bump to 4.3-r1. EAPI 5. Fix Java environment, see bug #472198. Fix use of CFLAGS, see bug #428188. Possibly bug #463582 is fixed as a side effect.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jss')
-rw-r--r--dev-java/jss/ChangeLog12
-rw-r--r--dev-java/jss/files/jss-4.3-cflags.patch11
-rw-r--r--dev-java/jss/files/jss-4.3-secitem.patch154
-rw-r--r--dev-java/jss/jss-4.3-r1.ebuild94
4 files changed, 269 insertions, 2 deletions
diff --git a/dev-java/jss/ChangeLog b/dev-java/jss/ChangeLog
index 253e3fc1da70..2c925709f8e5 100644
--- a/dev-java/jss/ChangeLog
+++ b/dev-java/jss/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/jss
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/ChangeLog,v 1.26 2012/05/03 07:42:50 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/ChangeLog,v 1.27 2013/06/05 09:30:15 tomwij Exp $
+
+*jss-4.3-r1 (05 Jun 2013)
+
+ 05 Jun 2013; Tom Wijsman <TomWij@gentoo.org> +files/jss-4.3-cflags.patch,
+ +files/jss-4.3-secitem.patch, +jss-4.3-r1.ebuild:
+ Revision bump to 4.3-r1. EAPI 5. Fix Java environment, see bug #472198. Fix
+ use of CFLAGS, see bug #428188. Possibly bug #463582 is fixed as a side
+ effect.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> jss-4.2.5.ebuild,
jss-4.3.ebuild:
diff --git a/dev-java/jss/files/jss-4.3-cflags.patch b/dev-java/jss/files/jss-4.3-cflags.patch
new file mode 100644
index 000000000000..3298a2765fc1
--- /dev/null
+++ b/dev-java/jss/files/jss-4.3-cflags.patch
@@ -0,0 +1,11 @@
+--- security/coreconf/command.mk 2007-10-23 23:55:00.000000000 +0200
++++ security/coreconf/command.mk.b 2013-06-05 11:15:31.092383902 +0200
+@@ -45,7 +45,7 @@
+ CCF = $(CC) $(CFLAGS)
+ LINK_DLL = $(LINK) $(OS_DLLFLAGS) $(DLLFLAGS)
+ LINK_EXE = $(LINK) $(OS_LFLAGS) $(LFLAGS)
+-CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
++CFLAGS += $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
+ $(XCFLAGS)
+ PERL = perl
+ RANLIB = echo
diff --git a/dev-java/jss/files/jss-4.3-secitem.patch b/dev-java/jss/files/jss-4.3-secitem.patch
new file mode 100644
index 000000000000..d9e7da394075
--- /dev/null
+++ b/dev-java/jss/files/jss-4.3-secitem.patch
@@ -0,0 +1,154 @@
+--- a/security/jss/org/mozilla/jss/CryptoManager.c 2008-05-22 06:28:09.000000000 +0200
++++ b/security/jss/org/mozilla/jss/CryptoManager.c 2013-06-05 11:09:58.649080012 +0200
+@@ -35,7 +35,7 @@
+ * ***** END LICENSE BLOCK ***** */
+ #include "_jni/org_mozilla_jss_CryptoManager.h"
+
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <secmod.h>
+ #include <cert.h>
+ #include <certt.h>
+--- a/security/jss/org/mozilla/jss/SecretDecoderRing/KeyManager.c 2003-12-19 20:36:30.000000000 +0100
++++ b/security/jss/org/mozilla/jss/SecretDecoderRing/KeyManager.c 2013-06-05 11:09:58.585746684 +0200
+@@ -36,7 +36,7 @@
+
+ #include "_jni/org_mozilla_jss_SecretDecoderRing_KeyManager.h"
+ #include <nspr.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <jss_exceptions.h>
+ #include <jssutil.h>
+ #include <pk11func.h>
+--- a/security/jss/org/mozilla/jss/crypto/PQGParams.c 2004-04-25 17:02:21.000000000 +0200
++++ b/security/jss/org/mozilla/jss/crypto/PQGParams.c 2013-06-05 11:09:58.589080017 +0200
+@@ -39,7 +39,7 @@
+ #include <nspr.h>
+
+ #include <plarena.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <secoidt.h>
+ #include <keyt.h> /* for PQGParams */
+ #include <pk11pqg.h>
+--- a/security/jss/org/mozilla/jss/crypto/SecretDecoderRing.c 2002-01-08 20:38:46.000000000 +0100
++++ b/security/jss/org/mozilla/jss/crypto/SecretDecoderRing.c 2013-06-05 11:09:58.585746684 +0200
+@@ -36,7 +36,7 @@
+
+ #include "_jni/org_mozilla_jss_crypto_SecretDecoderRing.h"
+ #include <nspr.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <pk11sdr.h>
+ #include <jss_exceptions.h>
+ #include <jssutil.h>
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11Cipher.c 2004-04-25 17:02:22.000000000 +0200
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11Cipher.c 2013-06-05 11:09:58.632413347 +0200
+@@ -40,7 +40,7 @@
+ #include <plarena.h>
+ #include <seccomon.h>
+ #include <pk11func.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+
+ /* JSS includes */
+ #include <java_ids.h>
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11KeyPairGenerator.c 2006-02-23 02:21:42.000000000 +0100
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11KeyPairGenerator.c 2013-06-05 11:09:58.595746684 +0200
+@@ -40,7 +40,7 @@
+ #include <pk11pqg.h>
+ #include <nspr.h>
+ #include <key.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+
+ #include <jssutil.h>
+ #include <pk11util.h>
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11KeyWrapper.c 2006-02-23 02:21:42.000000000 +0100
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11KeyWrapper.c 2013-06-05 11:09:58.629080014 +0200
+@@ -40,7 +40,7 @@
+ #include <plarena.h>
+ #include <seccomon.h>
+ #include <pk11func.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <keyt.h>
+
+ /* JSS includes */
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11MessageDigest.c 2004-04-25 17:02:22.000000000 +0200
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11MessageDigest.c 2013-06-05 11:09:58.609080016 +0200
+@@ -40,7 +40,7 @@
+ #include <plarena.h>
+ #include <seccomon.h>
+ #include <pk11func.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+
+ /* JSS includes */
+ #include <java_ids.h>
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11PrivKey.c 2006-04-25 03:26:42.000000000 +0200
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11PrivKey.c 2013-06-05 11:09:58.609080016 +0200
+@@ -43,7 +43,7 @@
+ #include <secerr.h>
+ #include <nspr.h>
+ #include <key.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+
+ #include <jss_bigint.h>
+ #include <jssutil.h>
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11Signature.c 2004-04-25 17:02:22.000000000 +0200
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11Signature.c 2013-06-05 11:09:58.605746683 +0200
+@@ -35,7 +35,7 @@
+ * ***** END LICENSE BLOCK ***** */
+
+ #include <nspr.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <secoidt.h>
+ #include <secmodt.h>
+ #include <pk11func.h>
+--- a/security/jss/org/mozilla/jss/pkcs11/PK11Token.c 2007-11-10 01:37:57.000000000 +0100
++++ b/security/jss/org/mozilla/jss/pkcs11/PK11Token.c 2013-06-05 11:09:58.622413348 +0200
+@@ -53,7 +53,7 @@
+ #include <jss_bigint.h>
+ #include <Algorithm.h>
+
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include "java_ids.h"
+
+ #include "pk11util.h"
+--- a/security/jss/org/mozilla/jss/ssl/callbacks.c 2004-09-03 20:32:03.000000000 +0200
++++ b/security/jss/org/mozilla/jss/ssl/callbacks.c 2013-06-05 11:09:58.565746686 +0200
+@@ -39,7 +39,7 @@
+ #include <nspr.h>
+ #include <java_ids.h>
+ #include <jss_exceptions.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include <jssutil.h>
+ #include <certt.h>
+ #include <keythi.h>
+--- a/security/jss/org/mozilla/jss/util/jssutil.c 2004-04-25 17:02:29.000000000 +0200
++++ b/security/jss/org/mozilla/jss/util/jssutil.c 2013-06-05 11:09:58.579080018 +0200
+@@ -38,7 +38,7 @@
+ #include <nspr.h>
+ #include <plstr.h>
+ #include <seccomon.h>
+-#include <secitem.h>
++#include <nss/secitem.h>
+ #include "jssutil.h"
+ #include "jss_bigint.h"
+ #include "jss_exceptions.h"
+--- a/security/jss/org/mozilla/jss/util/jssutil.h 2004-04-25 17:02:29.000000000 +0200
++++ b/security/jss/org/mozilla/jss/util/jssutil.h 2013-06-05 11:09:49.829080794 +0200
+@@ -39,7 +39,7 @@
+ /* Need to include these first.
+ * #include <nspr.h>
+ * #include <jni.h>
+- * #include <secitem.h>
++ * #include <nss/secitem.h>
+ */
+
+ PR_BEGIN_EXTERN_C
diff --git a/dev-java/jss/jss-4.3-r1.ebuild b/dev-java/jss/jss-4.3-r1.ebuild
new file mode 100644
index 000000000000..db88ef3a8085
--- /dev/null
+++ b/dev-java/jss/jss-4.3-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/jss-4.3-r1.ebuild,v 1.1 2013/06/05 09:30:15 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit base java-pkg-2 linux-info versionator
+
+RTM_NAME="JSS_${PV//./_}_RTM"
+
+DESCRIPTION="Network Security Services for Java (JSS)"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/jss/"
+# To prepare this tarball
+# cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot export \
+# -r JSS_4_3_RTM mozilla/security/coreconf
+# cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot export \
+# -r JSS_4_3_RTM mozilla/security/jss
+# tar cvjf jss-4.3.tar.bz2 mozilla
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MPL-1.1"
+SLOT="3.4"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND=">=dev-libs/nspr-4.7
+ >=dev-libs/nss-3.12"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/zip
+ virtual/pkgconfig
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+
+S="${WORKDIR}/mozilla"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4-target_source.patch
+ epatch "${FILESDIR}"/${PN}-4.2.5-use_pkg-config.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-secitem.patch
+}
+
+src_compile() {
+ export JAVA_GENTOO_OPTS="-source $(java-pkg_get-source) -target $(java-pkg_get-target)"
+
+ use amd64 && export USE_64=1
+
+ cd "${S}/security/coreconf" || die
+ # Hotfix for kernel 3.x #379283
+ get_running_version || die "Failed to determine kernel version"
+ if [[ ${KV_MAJOR} -ge 3 ]]; then
+ cp Linux2.6.mk Linux${KV_MAJOR}.${KV_MINOR}.mk || die
+ fi
+
+ emake -j1 BUILD_OPT=1
+
+ cd "${S}/security/jss" || die
+ emake -j1 BUILD_OPT=1 USE_PKGCONFIG=1 NSS_PKGCONFIG=nss NSPR_PKGCONFIG=nspr
+
+ if use doc; then
+ emake -j1 BUILD_OPT=1 javadoc
+ fi
+}
+
+# Investigate why this fails.
+#
+# cp: cannot stat ‘/var/tmp/portage/dev-java/jss-4.3-r1/work/mozilla/dist/Linux3.8_x86_64_glibc_PTH_64_OPT.OBJ//lib/*nssckbi*’: No such file or directory
+# Failed to copy builtins library at security/jss/org/mozilla/jss/tests/all.pl line 453.
+#
+# There is indeed no nssckbi file, investigation needed if that file can be
+# generated or whether we can remove the broken test; possibly inform upstream.
+RESTRICT="test"
+
+src_test() {
+ BUILD_OPT=1 perl security/jss/org/mozilla/jss/tests/all.pl dist \
+ "${S}"/dist/Linux*.OBJ/
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+
+ # Use this instead of the one in dist because it is a symlink
+ # and doso handles symlinks by just symlinking to the original
+ java-pkg_doso ./security/${PN}/lib/*/*.so
+
+ use doc && java-pkg_dojavadoc dist/jssdoc
+ use source && java-pkg_dosrc ./security/jss/org
+ use examples && java-pkg_doexamples ./security/jss/samples
+}