summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-11-16 16:15:14 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-11-16 16:15:14 +0000
commit79cabf463e0113a7a95d4c464ed4bd807e26ddc0 (patch)
tree4d3af08dc8eae7d2785ab9cf809e9744e67d2f73 /dev-java/httpunit
parentAdded ebuild from java-overlay (diff)
downloadgentoo-2-79cabf463e0113a7a95d4c464ed4bd807e26ddc0.tar.gz
gentoo-2-79cabf463e0113a7a95d4c464ed4bd807e26ddc0.tar.bz2
gentoo-2-79cabf463e0113a7a95d4c464ed4bd807e26ddc0.zip
Added ebuild from java-overlay
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-java/httpunit')
-rw-r--r--dev-java/httpunit/ChangeLog10
-rw-r--r--dev-java/httpunit/httpunit-1.6.2-r2.ebuild52
-rw-r--r--dev-java/httpunit/metadata.xml12
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-java/httpunit/ChangeLog b/dev-java/httpunit/ChangeLog
new file mode 100644
index 000000000000..155f8f462d7d
--- /dev/null
+++ b/dev-java/httpunit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/httpunit
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpunit/ChangeLog,v 1.1 2008/11/16 16:15:14 fordfrog Exp $
+
+*httpunit-1.6.2-r2 (16 Nov 2008)
+
+ 16 Nov 2008; Miroslav Šulc <fordfrog@gentoo.org>
+ +files/rhino-fix-1.6.2.diff, +metadata.xml, +httpunit-1.6.2-r2.ebuild:
+ Added ebuild from java-overlay
+
diff --git a/dev-java/httpunit/httpunit-1.6.2-r2.ebuild b/dev-java/httpunit/httpunit-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..53e102122a0b
--- /dev/null
+++ b/dev-java/httpunit/httpunit-1.6.2-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpunit/httpunit-1.6.2-r2.ebuild,v 1.1 2008/11/16 16:15:14 fordfrog Exp $
+
+EAPI="2"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="HttpUnit emulates the relevant portions of browser behavior."
+HOMEPAGE="http://httpunit.sourceforge.net/"
+# TODO what is metainf for?
+# TODO where did it come from?
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+CDEPEND="
+ >=dev-java/junit-3.8:0
+ dev-java/rhino:1.5
+ dev-java/jtidy:0
+ java-virtuals/servlet-api:2.3
+ dev-java/xerces:2"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ find "${S}" -name "*.jar" | xargs rm -v
+ cd "${S}"
+ epatch "${FILESDIR}/rhino-fix-${PV}.diff"
+ cd "${S}/jars"
+ java-pkg_jar-from junit,rhino-1.5,xerces-2,jtidy,servlet-api-2.3
+}
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+ eant clean jar $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_dojar "lib/${PN}.jar"
+ dodoc doc/*.txt
+ if use doc; then
+ dohtml -r doc/manual doc/tutorial
+ java-pkg_dojavadoc doc/api
+ fi
+}
diff --git a/dev-java/httpunit/metadata.xml b/dev-java/httpunit/metadata.xml
new file mode 100644
index 000000000000..8337051fb6b7
--- /dev/null
+++ b/dev-java/httpunit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ HttpUnit emulates the relevant portions of browser behavior,
+ including form submission, JavaScript, basic http authentication,
+ cookies and automatic page redirection, and allows Java test code
+ to examine returned pages either as text, an XML DOM, or containers
+ of forms, tables, and links.
+ </longdescription>
+</pkgmetadata>