summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-10 13:25:36 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-10 13:25:36 +0000
commit54ff546dc064e26ba0c5aa4e56967c19b98982aa (patch)
tree906fb0a14247275c62db73fdc73024e439206ef9 /dev-java/commons-validator/commons-validator-1.1.3.ebuild
parentStable macos. (Manifest recommit) (diff)
downloadgentoo-2-54ff546dc064e26ba0c5aa4e56967c19b98982aa.tar.gz
gentoo-2-54ff546dc064e26ba0c5aa4e56967c19b98982aa.tar.bz2
gentoo-2-54ff546dc064e26ba0c5aa4e56967c19b98982aa.zip
version bump
Diffstat (limited to 'dev-java/commons-validator/commons-validator-1.1.3.ebuild')
-rw-r--r--dev-java/commons-validator/commons-validator-1.1.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/commons-validator/commons-validator-1.1.3.ebuild b/dev-java/commons-validator/commons-validator-1.1.3.ebuild
new file mode 100644
index 000000000000..95a09a77761b
--- /dev/null
+++ b/dev-java/commons-validator/commons-validator-1.1.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.3.ebuild,v 1.1 2004/09/10 13:25:36 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jakarta component to validate user input, or data input"
+HOMEPAGE="http://jakarta.apache.org/commons/validator/"
+SRC_URI="mirror://apache/jakarta/commons/validator/source/${PN}-${PV}-src.tar.gz mirror://gentoo/commons-validator-1.1.3-gentoo-missingfiles.tar.bz2"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ app-arch/zip
+ jikes? ( dev-java/jikes )
+ junit? ( >=junit-3.8.1 )"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/oro-2.0.8
+ >=dev-java/commons-digester-1.5
+ >=dev-java/commons-collections-2.1
+ >=dev-java/commons-logging-1.0.3
+ >=dev-java/commons-beanutils-1.6
+ >=dev-java/xerces-2.6.2-r1"
+LICENSE="Apache-1.1"
+SLOT="0"
+RESTRICT="nomirror"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc jikes junit"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #dirty hack
+ sed -e 's:target name="compile" depends="static":target name="compile" depends="prepare":' -i build.xml
+
+ echo "oro.jar=`java-config --classpath=oro`" >> build.properties
+ echo "commons-digester.jar=`java-config --classpath=commons-digester`" >> build.properties
+ echo "commons-collections.jar=`java-config --classpath=commons-collections`" >> build.properties
+ echo "commons-logging.jar=`java-config --classpath=commons-logging | sed s/.*://`" >> build.properties
+ echo "commons-beanutils.jar=`java-config --classpath=commons-beanutils | sed s/.*://`" >> build.properties
+ echo "xerces.jar=`java-config --classpath=xerces-2`" >> build.properties
+ use junit && echo "junit.jar=`java-config --classpath=junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ ant ${antflags} || die "build failed"
+ jar -cvf ${PN}.jar -C target/classes/ . || die "could not create jar"
+}
+
+src_install() {
+ cd ${S}
+ java-pkg_dojar ${PN}.jar
+ use doc && dohtml -r dist/docs/
+ dohtml PROPOSAL.html STATUS.html
+ dodoc LICENSE.txt
+}