summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-22 04:30:13 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-22 04:30:13 +0000
commit07f45a8a181d7c24046ca1670376a5c77808593a (patch)
tree8ec89aaed58084310518de16f9320cd3bffbda47 /dev-java/commons-net
parentNew release: 0.9.15b (bug #115546) (diff)
downloadgentoo-2-07f45a8a181d7c24046ca1670376a5c77808593a.tar.gz
gentoo-2-07f45a8a181d7c24046ca1670376a5c77808593a.tar.bz2
gentoo-2-07f45a8a181d7c24046ca1670376a5c77808593a.zip
Version bump (bug #116226).
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/ChangeLog7
-rw-r--r--dev-java/commons-net/Manifest10
-rw-r--r--dev-java/commons-net/commons-net-1.4.1.ebuild54
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.4.11
4 files changed, 67 insertions, 5 deletions
diff --git a/dev-java/commons-net/ChangeLog b/dev-java/commons-net/ChangeLog
index cb6b4dcf621a..d89191e654cd 100644
--- a/dev-java/commons-net/ChangeLog
+++ b/dev-java/commons-net/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-net
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.29 2005/07/09 16:01:24 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.30 2005/12/22 04:30:13 nichoj Exp $
+
+*commons-net-1.4.1 (22 Dec 2005)
+
+ 22 Dec 2005; Joshua Nichols <nichoj@gentoo.org> +commons-net-1.4.1.ebuild:
+ Version bump (bug #116226).
09 Jul 2005; Thomas Matthijs <axxo@gentoo.org>
commons-net-1.2.2-r1.ebuild, commons-net-1.3.0-r1.ebuild:
diff --git a/dev-java/commons-net/Manifest b/dev-java/commons-net/Manifest
index 3a8f4483ff79..5cbca115e59c 100644
--- a/dev-java/commons-net/Manifest
+++ b/dev-java/commons-net/Manifest
@@ -1,8 +1,10 @@
+MD5 c433a5814268244b5c95bcd5b2fa3067 ChangeLog 3997
MD5 fab96c1bedb6e26d80b0e4e7ec7cfc2c commons-net-1.2.2-r1.ebuild 1337
-MD5 f9551c8fef6e71bc96b5051fc21e2534 ChangeLog 3855
-MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 7ca8c0733997ea75678f9a8a3efb32aa commons-net-1.3.0-r1.ebuild 1724
-MD5 e2628a3419f04cdb65cb4a3caad1c9df files/gentoo.diff 4678
-MD5 cd5dd0f16006dfa0491e9fb71981d402 files/gentoo-1.2.diff 3152
+MD5 7b565489e819aaa755000f9185ac98de commons-net-1.4.1.ebuild 1642
MD5 fb9978c1444923f864212fcb8914da67 files/digest-commons-net-1.2.2-r1 73
MD5 36815c4f205c7a6b95614626967da49b files/digest-commons-net-1.3.0-r1 73
+MD5 9e6a06d7cc59a78258f4806c4285918f files/digest-commons-net-1.4.1 73
+MD5 cd5dd0f16006dfa0491e9fb71981d402 files/gentoo-1.2.diff 3152
+MD5 e2628a3419f04cdb65cb4a3caad1c9df files/gentoo.diff 4678
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
diff --git a/dev-java/commons-net/commons-net-1.4.1.ebuild b/dev-java/commons-net/commons-net-1.4.1.ebuild
new file mode 100644
index 000000000000..3cc0e2e06d02
--- /dev/null
+++ b/dev-java/commons-net/commons-net-1.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.4.1.ebuild,v 1.1 2005/12/22 04:30:13 nichoj Exp $
+
+inherit eutils java-pkg
+
+MY_P="${P}-src"
+DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
+HOMEPAGE="http://jakarta.apache.org/commons/net/"
+SRC_URI="mirror://apache/jakarta/commons/net/source/${MY_P}.tar.gz"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/jakarta-oro-2.0"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-core-1.5.4
+ junit? ( dev-java/ant-tasks )
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )
+ ${RDEPEND}"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc64"
+# disabling unit tests:
+# http://issues.apache.org/bugzilla/show_bug.cgi?id=37985
+IUSE="doc examples jikes source" # junit
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
+
+ cd ${S}
+ # always disable tests
+ sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
+}
+
+src_compile() {
+ local antflags="jar -Dnoget=true"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "died on ant"
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dohtml -r dist/docs/
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r src/java/examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-net/files/digest-commons-net-1.4.1 b/dev-java/commons-net/files/digest-commons-net-1.4.1
new file mode 100644
index 000000000000..260959823188
--- /dev/null
+++ b/dev-java/commons-net/files/digest-commons-net-1.4.1
@@ -0,0 +1 @@
+MD5 ccbb3f67b55e8a7a676499db4386673c commons-net-1.4.1-src.tar.gz 229198