summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-05-19 04:24:09 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-05-19 04:24:09 +0000
commitd60e0260733d080a183c7859bd0b9ade8203fa29 (patch)
tree8392b7dd48bf98bba282196b96b66ac931cce526 /dev-java/commons-lang/commons-lang-2.0-r1.ebuild
parentFixed Makefile.in.in (Manifest recommit) (diff)
downloadgentoo-2-d60e0260733d080a183c7859bd0b9ade8203fa29.tar.gz
gentoo-2-d60e0260733d080a183c7859bd0b9ade8203fa29.tar.bz2
gentoo-2-d60e0260733d080a183c7859bd0b9ade8203fa29.zip
Closes #51082
Diffstat (limited to 'dev-java/commons-lang/commons-lang-2.0-r1.ebuild')
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-java/commons-lang/commons-lang-2.0-r1.ebuild b/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
index b4208fd36921..581d5942a4a3 100644
--- a/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
+++ b/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0-r1.ebuild,v 1.5 2004/05/14 02:52:40 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0-r1.ebuild,v 1.6 2004/05/19 04:24:09 zx Exp $
inherit java-pkg
@@ -20,6 +20,12 @@ IUSE="doc jikes junit"
S="${WORKDIR}/${PN}-${PV}-src"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use junit && echo "junit.jar=`java-config -p junit`" >> build.properties
+}
+
src_compile() {
local antflags="jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"