summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-13 17:07:16 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-13 17:07:16 +0000
commit91e4b3c5c9971a82f6bace330b860342c9a444d2 (patch)
tree6845758df568020c1bdc76d41b1bebafda1d2e6a /dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-91e4b3c5c9971a82f6bace330b860342c9a444d2.tar.gz
gentoo-2-91e4b3c5c9971a82f6bace330b860342c9a444d2.tar.bz2
gentoo-2-91e4b3c5c9971a82f6bace330b860342c9a444d2.zip
version bump
Diffstat (limited to 'dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild')
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild
new file mode 100644
index 000000000000..2dd96e2413bb
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild,v 1.1 2004/10/13 17:07:16 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
+HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
+SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${P/_/-}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc jikes"
+
+DEPEND=">=virtual/jdk-1.3
+ sys-apps/sed
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4
+ dev-java/commons-logging"
+RDEPEND=">=virtual/jdk-1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #make jikes happy
+ if use jikes; then
+ sed '837 s/ConnectionPool/org.apache.commons.httpclient.MultiThreadedHttpConnectionManager.ConnectionPool/' \
+ -i src/java/org/apache/commons/httpclient/MultiThreadedHttpConnectionManager.java \
+ || die "failed to sed"
+ fi
+
+ epatch ${FILESDIR}/gentoo.diff || die "patching failed"
+ echo "commons-logging.jar=/usr/share/commons-logging/lib/commons-logging.jar" >> build.properties
+}
+
+src_compile() {
+ local antflags="dist"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use doc && dohtml -r dist/docs/*
+}