summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-18 01:51:25 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-18 01:51:25 +0000
commitc8b0159c59811e0c6e7011d4083b38c71985dad9 (patch)
tree08cf451f1d8e7fa961f02e9dbf559c1afad5820d /dev-java/commons-collections
parentfix for java-commons_src_compile() make. should see both 'jar' and 'dist-jar... (diff)
downloadgentoo-2-c8b0159c59811e0c6e7011d4083b38c71985dad9.tar.gz
gentoo-2-c8b0159c59811e0c6e7011d4083b38c71985dad9.tar.bz2
gentoo-2-c8b0159c59811e0c6e7011d4083b38c71985dad9.zip
changed to use java-commons eclass.
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/ChangeLog8
-rw-r--r--dev-java/commons-collections/commons-collections-2.1-r3.ebuild25
-rw-r--r--dev-java/commons-collections/files/digest-commons-collections-2.1-r31
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index 7971dbf78e6a..4d66fbdaded3 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-collections
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.8 2003/03/16 23:59:04 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.9 2003/03/18 01:51:25 absinthe Exp $
+
+*commons-collections-2.1-r3 (17 Mar 2003)
+
+ 17 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-collections-2.1-r3.ebuild:
+ Changed to use java-commons eclass. Masked for testing.
*commons-collections-2.1-r2 (16 Mar 2003)
diff --git a/dev-java/commons-collections/commons-collections-2.1-r3.ebuild b/dev-java/commons-collections/commons-collections-2.1-r3.ebuild
new file mode 100644
index 000000000000..b54ef090260f
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-2.1-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.1-r3.ebuild,v 1.1 2003/03/18 01:51:25 absinthe Exp $
+
+inherit java-commons
+
+S=${WORKDIR}/${PN}-${PV}-src
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=ant-1.4
+ junit? ( >=dev-java/junit-3.7 )
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ java-commons_src_compile myconf make
+ use doc && java-commons_src_compile makedoc
+}
+
diff --git a/dev-java/commons-collections/files/digest-commons-collections-2.1-r3 b/dev-java/commons-collections/files/digest-commons-collections-2.1-r3
new file mode 100644
index 000000000000..f2de34acfce0
--- /dev/null
+++ b/dev-java/commons-collections/files/digest-commons-collections-2.1-r3
@@ -0,0 +1 @@
+MD5 ee30c02b1b57693f72cd86c899b925d9 commons-collections-2.1-src.tar.gz 229173