summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-11-12 23:49:23 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-11-12 23:49:23 +0000
commitac5dd7531a35848cccef22e27505bd12e4c438c8 (patch)
treee189607caecc50305a630a9d56ad37ca70d73f11 /dev-java/commons-attributes
parentRevbump to fix remaining broken init scripts out there, fixes bug #198661. Th... (diff)
downloadgentoo-2-ac5dd7531a35848cccef22e27505bd12e4c438c8.tar.gz
gentoo-2-ac5dd7531a35848cccef22e27505bd12e4c438c8.tar.bz2
gentoo-2-ac5dd7531a35848cccef22e27505bd12e4c438c8.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-java/commons-attributes')
-rw-r--r--dev-java/commons-attributes/ChangeLog8
-rw-r--r--dev-java/commons-attributes/commons-attributes-2.2.ebuild50
-rw-r--r--dev-java/commons-attributes/files/digest-commons-attributes-2.23
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-java/commons-attributes/ChangeLog b/dev-java/commons-attributes/ChangeLog
index 30c645b475b7..6a3de87cda97 100644
--- a/dev-java/commons-attributes/ChangeLog
+++ b/dev-java/commons-attributes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-attributes
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.7 2007/04/25 21:31:21 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.8 2007/11/12 23:49:23 betelgeuse Exp $
+
+*commons-attributes-2.2 (12 Nov 2007)
+
+ 12 Nov 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +commons-attributes-2.2.ebuild:
+ Version bump.
25 Apr 2007; Vlastimil Babka <caster@gentoo.org>
commons-attributes-2.1-r1.ebuild:
diff --git a/dev-java/commons-attributes/commons-attributes-2.2.ebuild b/dev-java/commons-attributes/commons-attributes-2.2.ebuild
new file mode 100644
index 000000000000..d038a27a8546
--- /dev/null
+++ b/dev-java/commons-attributes/commons-attributes-2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/commons-attributes-2.2.ebuild,v 1.1 2007/11/12 23:49:23 betelgeuse Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Attributes enables Java programmers to use C#/.Net-style attributes in their code."
+HOMEPAGE="http://jakarta.apache.org/commons/attributes/"
+SRC_URI="mirror://apache/jakarta/commons/attributes/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/xjavadoc
+ dev-java/gjdoc
+ dev-java/ant-core
+ dev-java/qdox:1.6"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from gjdoc
+ java-pkg_jar-from qdox-1.6
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-compiler-${PV}.jar ${PN}-compiler.jar
+
+ java-pkg_register-ant-task
+
+ dodoc NOTICE.txt || die
+ dohtml README.html || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc api/src/java/org compiler/src/java/org
+}
diff --git a/dev-java/commons-attributes/files/digest-commons-attributes-2.2 b/dev-java/commons-attributes/files/digest-commons-attributes-2.2
new file mode 100644
index 000000000000..07b7f2a601f1
--- /dev/null
+++ b/dev-java/commons-attributes/files/digest-commons-attributes-2.2
@@ -0,0 +1,3 @@
+MD5 25b64e50f920cdc5491319f388dc42c0 commons-attributes-2.2-src.tar.gz 98307
+RMD160 31a0ec5463dff5c097c0cbbaf07ea4dbc998abc6 commons-attributes-2.2-src.tar.gz 98307
+SHA256 f24acddd1b82db16052672c255bd57add05107bbb1220264aec6ba10091e7713 commons-attributes-2.2-src.tar.gz 98307