summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-05-17 10:19:36 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-05-17 10:19:36 +0000
commitfe58868691b93429a5e8a644e261805a912bf1d7 (patch)
tree529b512bdd94d26a8cada46c522550baefa42ceb /dev-java/bytelist
parentVersion bump (bug #319187). (diff)
downloadgentoo-2-fe58868691b93429a5e8a644e261805a912bf1d7.tar.gz
gentoo-2-fe58868691b93429a5e8a644e261805a912bf1d7.tar.bz2
gentoo-2-fe58868691b93429a5e8a644e261805a912bf1d7.zip
Version Bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/bytelist')
-rw-r--r--dev-java/bytelist/ChangeLog7
-rw-r--r--dev-java/bytelist/bytelist-1.0.6.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-java/bytelist/ChangeLog b/dev-java/bytelist/ChangeLog
index 197c2267bffd..6a7858466a85 100644
--- a/dev-java/bytelist/ChangeLog
+++ b/dev-java/bytelist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/bytelist
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bytelist/ChangeLog,v 1.8 2010/01/03 20:18:59 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bytelist/ChangeLog,v 1.9 2010/05/17 10:19:36 ali_bush Exp $
+
+*bytelist-1.0.6 (17 May 2010)
+
+ 17 May 2010; Alistair Bush <ali_bush@gentoo.org> +bytelist-1.0.6.ebuild:
+ Version Bump.
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
bytelist-1.0.2.ebuild:
diff --git a/dev-java/bytelist/bytelist-1.0.6.ebuild b/dev-java/bytelist/bytelist-1.0.6.ebuild
new file mode 100644
index 000000000000..7de98aa4bc28
--- /dev/null
+++ b/dev-java/bytelist/bytelist-1.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bytelist/bytelist-1.0.6.ebuild,v 1.1 2010/05/17 10:19:36 ali_bush Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="source test"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JRuby support library"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/jcodings"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/jcodings
+ test? ( dev-java/ant-junit )"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="jcodings"
+
+java_prepare() {
+ # Don't do tests unnecessarily.
+ sed -i 's:depends="test":depends="compile":' build.xml
+}
+
+src_install() {
+ java-pkg_newjar lib/${PN}-1.0.1.jar
+ use source && java-pkg_dosrc src/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}