summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-08 12:59:35 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-08 12:59:35 +0000
commit30c4d509b03b7ffcad43332a88a2abe71f1ecb71 (patch)
tree631f9e791161110e030d5ede8c0616e7c4beff9a /dev-java/bytelist
parentRemove mask on dev-java/pat, USE=doc works after a trivial fix. (diff)
downloadgentoo-2-30c4d509b03b7ffcad43332a88a2abe71f1ecb71.tar.gz
gentoo-2-30c4d509b03b7ffcad43332a88a2abe71f1ecb71.tar.bz2
gentoo-2-30c4d509b03b7ffcad43332a88a2abe71f1ecb71.zip
Version bump to 1.0.10.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/bytelist')
-rw-r--r--dev-java/bytelist/ChangeLog10
-rw-r--r--dev-java/bytelist/bytelist-1.0.10.ebuild50
2 files changed, 57 insertions, 3 deletions
diff --git a/dev-java/bytelist/ChangeLog b/dev-java/bytelist/ChangeLog
index 3f43f3ce475c..7ff4b5d58575 100644
--- a/dev-java/bytelist/ChangeLog
+++ b/dev-java/bytelist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/bytelist
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bytelist/ChangeLog,v 1.17 2012/05/09 17:07:57 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bytelist/ChangeLog,v 1.18 2013/07/08 12:59:35 tomwij Exp $
+
+*bytelist-1.0.10 (08 Jul 2013)
+
+ 08 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +bytelist-1.0.10.ebuild:
+ Version bump to 1.0.10.
09 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> bytelist-1.0.9.ebuild:
x86 stable wrt bug #396305
@@ -66,4 +71,3 @@
15 Nov 2008; Miroslav Šulc <fordfrog@gentoo.org> +metadata.xml,
+bytelist-1.0.ebuild:
Ebuild moved from java-overlay to the main tree. Ebuild created by Chewi.
-
diff --git a/dev-java/bytelist/bytelist-1.0.10.ebuild b/dev-java/bytelist/bytelist-1.0.10.ebuild
new file mode 100644
index 000000000000..d46f259c3770
--- /dev/null
+++ b/dev-java/bytelist/bytelist-1.0.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bytelist/bytelist-1.0.10.ebuild,v 1.1 2013/07/08 12:59:35 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JRuby support library"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="https://github.com/jruby/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEP="dev-java/jcodings:0"
+
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.5"
+
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/jruby-${PN}-* "${WORKDIR}"/${P} || die
+}
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_GENTOO_CLASSPATH="jcodings"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}