summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-20 02:26:30 +0000
committerMark Wright <gienah@gentoo.org>2013-10-20 02:26:30 +0000
commitf52e4cca79ce7e150f0e8019ab2de6e1298e16bb (patch)
tree58cedcc02ad68cda6579a7a0a55073f18e39dae9 /dev-haskell
parentBump happstack-server to 7.3.1 (diff)
downloadgentoo-2-f52e4cca79ce7e150f0e8019ab2de6e1298e16bb.tar.gz
gentoo-2-f52e4cca79ce7e150f0e8019ab2de6e1298e16bb.tar.bz2
gentoo-2-f52e4cca79ce7e150f0e8019ab2de6e1298e16bb.zip
Bump conduit to 1.0.8
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/conduit/ChangeLog8
-rw-r--r--dev-haskell/conduit/conduit-1.0.8.ebuild46
-rw-r--r--dev-haskell/conduit/metadata.xml3
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-haskell/conduit/ChangeLog b/dev-haskell/conduit/ChangeLog
index 2ed5f5d9e43c..a1f65982ddab 100644
--- a/dev-haskell/conduit/ChangeLog
+++ b/dev-haskell/conduit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/conduit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.2 2013/09/13 05:48:52 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.3 2013/10/20 02:26:30 gienah Exp $
+
+*conduit-1.0.8 (20 Oct 2013)
+
+ 20 Oct 2013; Mark Wright <gienah@gentoo.org> +conduit-1.0.8.ebuild,
+ metadata.xml:
+ Bump conduit to 1.0.8
*conduit-1.0.7.4 (13 Sep 2013)
diff --git a/dev-haskell/conduit/conduit-1.0.8.ebuild b/dev-haskell/conduit/conduit-1.0.8.ebuild
new file mode 100644
index 000000000000..d078d114017b
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/conduit-1.0.8.ebuild,v 1.1 2013/10/20 02:26:30 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Streaming data processing library."
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="nohandles"
+
+RDEPEND=">=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/mmorph:=[profile?]
+ >=dev-haskell/monad-control-0.3.1:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-base-0.4.1:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/doctest-0.8
+ >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.7-doctest.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag nohandles nohandles)
+}
diff --git a/dev-haskell/conduit/metadata.xml b/dev-haskell/conduit/metadata.xml
index ffba81f0dcfe..59ad47ec8163 100644
--- a/dev-haskell/conduit/metadata.xml
+++ b/dev-haskell/conduit/metadata.xml
@@ -8,4 +8,7 @@
<longdescription>
Conduits are an approach to the streaming data problem. It is meant as an alternative to enumerators\/iterators, hoping to address the same issues with different trade-offs based on real-world experience with enumerators. For more information, see &lt;http://www.yesodweb.com/blog/2011/12/conduits&gt;.
</longdescription>
+ <use>
+ <flag name='nohandles'>experimental code to use raw system calls in place of handles. Not recommended for general use</flag>
+ </use>
</pkgmetadata>