summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-11-11 17:56:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-11-11 17:56:11 +0000
commitcc868ae7c80593d870fc936a216c48d3941fff02 (patch)
treeea68b3a239df6690aa0e06aecbe46e8251ce066c /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-cc868ae7c80593d870fc936a216c48d3941fff02.tar.gz
gentoo-2-cc868ae7c80593d870fc936a216c48d3941fff02.tar.bz2
gentoo-2-cc868ae7c80593d870fc936a216c48d3941fff02.zip
Fix build failure against ghc-7.4 (bug #442746 by Fabian Holler)
(Portage version: 2.2.0_alpha142_p5/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/json/ChangeLog6
-rw-r--r--dev-haskell/json/files/json-0.4.3-ghc-7.4.patch10
-rw-r--r--dev-haskell/json/json-0.4.3.ebuild6
-rw-r--r--dev-haskell/json/json-0.4.4.ebuild6
4 files changed, 23 insertions, 5 deletions
diff --git a/dev-haskell/json/ChangeLog b/dev-haskell/json/ChangeLog
index a1f8e09b81e4..7891bc671072 100644
--- a/dev-haskell/json/ChangeLog
+++ b/dev-haskell/json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/ChangeLog,v 1.6 2012/09/12 14:57:34 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/ChangeLog,v 1.7 2012/11/11 17:56:10 slyfox Exp $
+
+ 11 Nov 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/json-0.4.3-ghc-7.4.patch, json-0.4.3.ebuild, json-0.4.4.ebuild:
+ Fix build failure against ghc-7.4 (bug #442746 by Fabian Holler)
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> json-0.4.3.ebuild,
json-0.4.4.ebuild, json-0.5.ebuild:
diff --git a/dev-haskell/json/files/json-0.4.3-ghc-7.4.patch b/dev-haskell/json/files/json-0.4.3-ghc-7.4.patch
new file mode 100644
index 000000000000..3d1233de69fb
--- /dev/null
+++ b/dev-haskell/json/files/json-0.4.3-ghc-7.4.patch
@@ -0,0 +1,10 @@
+diff --git a/Text/JSON.hs b/Text/JSON.hs
+index 900e0f8..5b90a2a 100644
+--- a/Text/JSON.hs
++++ b/Text/JSON.hs
+@@ -1,4 +1,4 @@
+-{-# OPTIONS_GHC -XCPP -XMultiParamTypeClasses -XTypeSynonymInstances #-}
++{-# OPTIONS_GHC -XCPP -XMultiParamTypeClasses -XTypeSynonymInstances -XFlexibleInstances #-}
+ --------------------------------------------------------------------
+ -- |
+ -- Module : Text.JSON
diff --git a/dev-haskell/json/json-0.4.3.ebuild b/dev-haskell/json/json-0.4.3.ebuild
index cb4f6a159d94..ac7d9c137288 100644
--- a/dev-haskell/json/json-0.4.3.ebuild
+++ b/dev-haskell/json/json-0.4.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/json-0.4.3.ebuild,v 1.5 2012/09/12 14:57:34 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/json-0.4.3.ebuild,v 1.6 2012/11/11 17:56:10 slyfox Exp $
CABAL_FEATURES="lib profile haddock"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="Support for serialising Haskell to and from JSON"
HOMEPAGE="http://hackage.haskell.org/package/json"
@@ -25,3 +25,5 @@ RDEPEND=">=dev-lang/ghc-6.10
dev-haskell/parsec"
DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-7.4.patch)
diff --git a/dev-haskell/json/json-0.4.4.ebuild b/dev-haskell/json/json-0.4.4.ebuild
index c6754293b5fd..bd920e136b1b 100644
--- a/dev-haskell/json/json-0.4.4.ebuild
+++ b/dev-haskell/json/json-0.4.4.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/json-0.4.4.ebuild,v 1.2 2012/09/12 14:57:34 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/json/json-0.4.4.ebuild,v 1.3 2012/11/11 17:56:10 slyfox Exp $
# ebuild generated by hackport 0.2.13
EAPI="3"
CABAL_FEATURES="lib profile haddock hscolour"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="Support for serialising Haskell to and from JSON"
HOMEPAGE="http://hackage.haskell.org/package/json"
@@ -27,6 +27,8 @@ RDEPEND="dev-haskell/mtl
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2.0"
+PATCHES=("${FILESDIR}"/${PN}-0.4.3-ghc-7.4.patch)
+
src_configure() {
cabal_src_configure \
$(cabal_flag generic) \