summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-03-03 17:12:17 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-03-03 17:12:17 +0000
commitb7c4fe00ae4e319a47a28ce0c0a74df9802aee32 (patch)
tree8a0b2ed57ae6610b04eff18f829977d76544c7de /dev-haskell
parentmark 0.90 stable on x86 (Manifest recommit) (diff)
downloadgentoo-2-b7c4fe00ae4e319a47a28ce0c0a74df9802aee32.tar.gz
gentoo-2-b7c4fe00ae4e319a47a28ce0c0a74df9802aee32.tar.bz2
gentoo-2-b7c4fe00ae4e319a47a28ce0c0a74df9802aee32.zip
initial import of wxhaskell
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wxhaskell/ChangeLog11
-rw-r--r--dev-haskell/wxhaskell/Manifest11
-rw-r--r--dev-haskell/wxhaskell/files/digest-wxhaskell-0.62
-rw-r--r--dev-haskell/wxhaskell/metadata.xml8
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.6.ebuild81
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
new file mode 100644
index 000000000000..4fb72954bf63
--- /dev/null
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/wxhaskell
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.1 2004/03/03 17:12:17 kosmikus Exp $
+
+*wxhaskell-0.6 (03 Mar 2004)
+
+ 03 Mar 2004; Andres Loeh <kosmikus@gentoo.org> metadata.xml,
+ wxhaskell-0.6.ebuild:
+ wxHaskell is a Haskell binding for the wxWidgets library. First import into
+ portage.
+
diff --git a/dev-haskell/wxhaskell/Manifest b/dev-haskell/wxhaskell/Manifest
new file mode 100644
index 000000000000..b9384140ef54
--- /dev/null
+++ b/dev-haskell/wxhaskell/Manifest
@@ -0,0 +1,11 @@
+MD5 669467a5048a6dc2dff2dbbd6b2e9dfb wxhaskell-0.2.ebuild 1842
+MD5 cae6e948d42ace27896dcd4a70dfab78 wxhaskell-0.4.ebuild~ 2226
+MD5 c2b6c8894953f81781e53a57ecf0574c wxhaskell-0.4.ebuild 2406
+MD5 f8739b913e0f1f5b5bbf14548b087848 wxhaskell-0.6.ebuild 2404
+MD5 669467a5048a6dc2dff2dbbd6b2e9dfb wxhaskell-0.3.ebuild~ 1842
+MD5 9abe53b569595723813dfb4757bce8ad wxhaskell-0.3.ebuild 2101
+MD5 8fc444e963ee737fbd7e7b1651da166c files/digest-wxhaskell-0.1 132
+MD5 212b42d7d430721c81a0fa17dffb72c4 files/digest-wxhaskell-0.2 132
+MD5 a61004f795b3830a9896ea6a09fdcdd6 files/digest-wxhaskell-0.3 132
+MD5 1495c896cf99d136f494503b1056034c files/digest-wxhaskell-0.4 132
+MD5 3370d9be457b4e8fa9b80ec89b49f30b files/digest-wxhaskell-0.6 132
diff --git a/dev-haskell/wxhaskell/files/digest-wxhaskell-0.6 b/dev-haskell/wxhaskell/files/digest-wxhaskell-0.6
new file mode 100644
index 000000000000..6598dfecc1e2
--- /dev/null
+++ b/dev-haskell/wxhaskell/files/digest-wxhaskell-0.6
@@ -0,0 +1,2 @@
+MD5 ff5889eb6893da83092938541fbe9b61 wxhaskell-src-0.6.zip 506746
+MD5 627425cccd501cfa7ccd362267fad890 wxhaskell-doc-0.6.zip 838337
diff --git a/dev-haskell/wxhaskell/metadata.xml b/dev-haskell/wxhaskell/metadata.xml
new file mode 100644
index 000000000000..a53a18c06081
--- /dev/null
+++ b/dev-haskell/wxhaskell/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>kosmikus@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.6.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.6.ebuild
new file mode 100644
index 000000000000..6f4dad333bad
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.6.ebuild,v 1.1 2004/03/03 17:12:17 kosmikus Exp $
+
+DESCRIPTION="a portable and native GUI library for Haskell"
+HOMEPAGE="http://wxhaskell.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxhaskell/${PN}-src-${PV}.zip"
+LICENSE="wxWinLL-3"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="doc"
+
+DEPEND="${DEPEND}
+ >=virtual/ghc-6.2
+ >=x11-libs/wxGTK-2.4.1
+ doc? ( >=dev-haskell/haddock-0.6-r2 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # non-standard configure, so econf is not an option
+ mv configure configure.orig
+ # adapt to Gentoo path convention
+ sed -e 's:/doc/html:/share/doc/html:' \
+ -e 's:wxwinlibs="`$.*$:wxwinlibs="`$wxconfig --libs` `$wxconfig --gl-libs`":' \
+ configure.orig > configure
+ # sed -e 's:test "$wxwinlib\":test "":' configure.orig > configure
+ chmod u+x ./configure
+ # determine ghc library directory
+ # (so that it's possible to install the library for
+ # multiple versions of ghc)
+ local ghc_version
+ local myopts
+ ghc_version=`best_version virtual/ghc | sed "s:.*/::"`
+ test -n ${ghc_version} && ghclibdir="/usr/lib/${ghc_version}"
+ test -n ${ghclibdir} || ghclibdir="/usr/lib"
+ test -n ${ghclibdir} && myopts="${myopts} --libdir=${D}/${ghclibdir}"
+ ./configure \
+ --prefix=${D}/usr \
+ --hcpkg=/bin/true \
+ ${myopts} \
+ || die "./configure failed"
+ # emake doesn't work
+ make || die "make failed"
+ # create documentation
+ if [ `use doc` ]; then
+ make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ make install || die "make install failed"
+ if [ `use doc` ]; then
+ dohtml -A haddock -r out/doc/*
+ cp -r samples ${D}/usr/share/doc/${PF}
+ fi
+}
+
+pkg_postinst() {
+ einfo "Registering wxcore package"
+ wxhlibdir=${ghclibdir} ghc-pkg -u -i ${S}/config/wxcore.pkg
+ einfo "Registering wx package"
+ wxhlibdir=${ghclibdir} ghc-pkg -u -i ${S}/config/wx.pkg
+}
+
+pkg_postrm() {
+ # check if another version is still there
+ has_version "<${CATEGORY}/${PF}" \
+ || has_version ">${CATEGORY}/${PF}" \
+ || unregister_ghc_packages
+}
+
+unregister_ghc_packages() {
+ einfo "Unregistering wx package"
+ /usr/bin/ghc-pkg -r wx
+ einfo "Unregistering wxcore package"
+ /usr/bin/ghc-pkg -r wxcore
+}
+