summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-07-28 18:47:34 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-07-28 18:47:34 +0000
commit5c5ac149a66e792afe6065f8b66268a20c708ba8 (patch)
tree559e7f2c1304a428edbb614a611b4a146a3a6964 /dev-haskell/x11
parentVersion bump. Bug #214750 - fix automagic deps on kerberos, ssl, sasl. (diff)
downloadgentoo-2-5c5ac149a66e792afe6065f8b66268a20c708ba8.tar.gz
gentoo-2-5c5ac149a66e792afe6065f8b66268a20c708ba8.tar.bz2
gentoo-2-5c5ac149a66e792afe6065f8b66268a20c708ba8.zip
Version bump dev-haskell/x11
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/x11')
-rw-r--r--dev-haskell/x11/ChangeLog7
-rw-r--r--dev-haskell/x11/x11-1.4.5.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-haskell/x11/ChangeLog b/dev-haskell/x11/ChangeLog
index 77555e349865..4cb0f8eeee61 100644
--- a/dev-haskell/x11/ChangeLog
+++ b/dev-haskell/x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/x11
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.12 2009/07/21 16:25:53 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.13 2009/07/28 18:47:34 kolmodin Exp $
+
+*x11-1.4.5 (28 Jul 2009)
+
+ 28 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org> +x11-1.4.5.ebuild:
+ Version bump.
21 Jul 2009; <chainsaw@gentoo.org> x11-1.4.2.ebuild:
Marked stable on AMD64 as requested by Lennart Kolmodin
diff --git a/dev-haskell/x11/x11-1.4.5.ebuild b/dev-haskell/x11/x11-1.4.5.ebuild
new file mode 100644
index 000000000000..d89954550f97
--- /dev/null
+++ b/dev-haskell/x11/x11-1.4.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.5.ebuild,v 1.1 2009/07/28 18:47:34 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal eutils
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="http://darcs.haskell.org/X11"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="xinerama"
+
+RDEPEND=">=dev-lang/ghc-6.4.2
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3.0"
+
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--configure-option=$(use_with xinerama)"
+ cabal_src_compile
+}