summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-03 05:22:10 +0000
committerMark Wright <gienah@gentoo.org>2015-04-03 05:22:10 +0000
commit3f39a77aa4884a1f06fbbf8ea39fa554f491a494 (patch)
tree24090ae5d320e936f600dcfc73514a750ecf7e19 /dev-haskell/vector
parentBump vector-algorithms to 0.6.0.4 (diff)
downloadgentoo-2-3f39a77aa4884a1f06fbbf8ea39fa554f491a494.tar.gz
gentoo-2-3f39a77aa4884a1f06fbbf8ea39fa554f491a494.tar.bz2
gentoo-2-3f39a77aa4884a1f06fbbf8ea39fa554f491a494.zip
Bump vector to 0.10.12.3
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/vector')
-rw-r--r--dev-haskell/vector/ChangeLog7
-rw-r--r--dev-haskell/vector/vector-0.10.12.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-haskell/vector/ChangeLog b/dev-haskell/vector/ChangeLog
index c0f8a49779a4..0a3953a59e3e 100644
--- a/dev-haskell/vector/ChangeLog
+++ b/dev-haskell/vector/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/vector
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/ChangeLog,v 1.22 2015/02/20 13:14:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/ChangeLog,v 1.23 2015/04/03 05:22:10 gienah Exp $
+
+*vector-0.10.12.3 (03 Apr 2015)
+
+ 03 Apr 2015; Mark Wright <gienah@gentoo.org> +vector-0.10.12.3.ebuild:
+ Bump vector to 0.10.12.3
20 Feb 2015; Raúl Porcel <armin76@gentoo.org> vector-0.10.0.1.ebuild:
alpha/ia64 stable wrt #480568
diff --git a/dev-haskell/vector/vector-0.10.12.3.ebuild b/dev-haskell/vector/vector-0.10.12.3.ebuild
new file mode 100644
index 000000000000..436b2d242069
--- /dev/null
+++ b/dev-haskell/vector/vector-0.10.12.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/vector-0.10.12.3.ebuild,v 1.1 2015/04/03 05:22:10 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient Arrays"
+HOMEPAGE="https://github.com/haskell/vector"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+boundschecks internalchecks unsafechecks"
+
+RDEPEND=">=dev-haskell/primitive-0.5.0.1:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9
+ dev-haskell/random
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ >=dev-haskell/transformers-0.2.0.0 )
+"
+
+src_prepare() {
+ local can_spec_const="yes"
+
+ cabal_chdeps \
+ "QuickCheck >= 2.7 && < 2.8" "QuickCheck >= 2.7 && < 2.9"
+
+ ghc-supports-interpreter || can_spec_const="no"
+
+ # ghci-less GHC can't do ANN #482960
+ if [[ ${can_spec_const} == "no" ]]; then
+ einfo "Disabling 'ForceSpecConstr' due to bug #482960"
+ sed -e 's/{-# ANN type SPEC ForceSpecConstr #-}/{- # ANN type SPEC ForceSpecConstr #-}/' \
+ -i Data/Vector/Fusion/Stream/Monadic.hs || die
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag boundschecks boundschecks) \
+ $(cabal_flag internalchecks internalchecks) \
+ $(cabal_flag unsafechecks unsafechecks)
+}