summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 13:27:32 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 13:27:32 +0000
commit383741952f832809db5c92ec8f06aeb8b549bc1c (patch)
treeb92b30b90b8f4016d47dc9a6505e07bd840143f2 /dev-haskell/vector-algorithms
parentBump yesod to 1.2.5 (diff)
downloadgentoo-2-383741952f832809db5c92ec8f06aeb8b549bc1c.tar.gz
gentoo-2-383741952f832809db5c92ec8f06aeb8b549bc1c.tar.bz2
gentoo-2-383741952f832809db5c92ec8f06aeb8b549bc1c.zip
Bump vector-algorithms to 0.6.0.1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/vector-algorithms')
-rw-r--r--dev-haskell/vector-algorithms/ChangeLog10
-rw-r--r--dev-haskell/vector-algorithms/metadata.xml7
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.6.0.1.ebuild39
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-haskell/vector-algorithms/ChangeLog b/dev-haskell/vector-algorithms/ChangeLog
index e2756280a3fa..06d67dcbad08 100644
--- a/dev-haskell/vector-algorithms/ChangeLog
+++ b/dev-haskell/vector-algorithms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/vector-algorithms
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector-algorithms/ChangeLog,v 1.1 2013/08/25 06:38:13 qnikst Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector-algorithms/ChangeLog,v 1.2 2014/03/09 13:27:32 gienah Exp $
+
+*vector-algorithms-0.6.0.1 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org>
+ +vector-algorithms-0.6.0.1.ebuild, metadata.xml:
+ Bump vector-algorithms to 0.6.0.1
*vector-algorithms-0.5.4.2 (25 Aug 2013)
diff --git a/dev-haskell/vector-algorithms/metadata.xml b/dev-haskell/vector-algorithms/metadata.xml
index 8a8216dce180..a6259edf5797 100644
--- a/dev-haskell/vector-algorithms/metadata.xml
+++ b/dev-haskell/vector-algorithms/metadata.xml
@@ -5,6 +5,13 @@
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="bench">Build a benchmarking program.</flag>
+ <flag name="boundschecks">Enable bounds checking.</flag>
+ <flag name="internalchecks">Enable internal consistency checks at the cost of a significant performance penalty.</flag>
+ <flag name="properties">Enable quickcheck tests.</flag>
+ <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a significant performance penalty.</flag>
+ </use>
<longdescription>
Efficient algorithms for vector arrays
</longdescription>
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.1.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.1.ebuild
new file mode 100644
index 000000000000..22b562ff2bbe
--- /dev/null
+++ b/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.1.ebuild,v 1.1 2014/03/09 13:27:32 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient algorithms for vector arrays"
+HOMEPAGE="http://code.haskell.org/~dolio/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="bench +boundschecks internalchecks +properties unsafechecks"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/mwc-random:=[profile?]
+ >=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( properties? ( >=dev-haskell/quickcheck-2 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bench bench) \
+ $(cabal_flag boundschecks boundschecks) \
+ $(cabal_flag internalchecks internalchecks) \
+ $(cabal_flag properties properties) \
+ $(cabal_flag unsafechecks unsafechecks)
+}