summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-02 13:01:19 +0000
committerMark Wright <gienah@gentoo.org>2013-04-02 13:01:19 +0000
commitcd78e05007bedc5eea678bf4e70f6e201c545939 (patch)
treecc7067b511bdd24233fc8923496995488e406f23 /dev-haskell/testpack
parentBump test-framework-quickcheck2 to 0.3.0.1-r1 (diff)
downloadgentoo-2-cd78e05007bedc5eea678bf4e70f6e201c545939.tar.gz
gentoo-2-cd78e05007bedc5eea678bf4e70f6e201c545939.tar.bz2
gentoo-2-cd78e05007bedc5eea678bf4e70f6e201c545939.zip
Bump testpack to 2.1.2.1
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/testpack')
-rw-r--r--dev-haskell/testpack/ChangeLog10
-rw-r--r--dev-haskell/testpack/files/testpack-2.1.2.1-quickcheck-2.6.patch45
-rw-r--r--dev-haskell/testpack/testpack-2.1.2.1.ebuild30
3 files changed, 83 insertions, 2 deletions
diff --git a/dev-haskell/testpack/ChangeLog b/dev-haskell/testpack/ChangeLog
index af493ad5269b..b0830d901ee9 100644
--- a/dev-haskell/testpack/ChangeLog
+++ b/dev-haskell/testpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/testpack
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/testpack/ChangeLog,v 1.8 2012/12/07 17:59:52 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/testpack/ChangeLog,v 1.9 2013/04/02 13:01:19 gienah Exp $
+
+*testpack-2.1.2.1 (02 Apr 2013)
+
+ 02 Apr 2013; Mark Wright <gienah@gentoo.org>
+ +files/testpack-2.1.2.1-quickcheck-2.6.patch, +testpack-2.1.2.1.ebuild:
+ Bump testpack to 2.1.2.1
07 Dec 2012; <ago@gentoo.org> testpack-2.1.2.ebuild:
Stable for x86, wrt bug #441160
diff --git a/dev-haskell/testpack/files/testpack-2.1.2.1-quickcheck-2.6.patch b/dev-haskell/testpack/files/testpack-2.1.2.1-quickcheck-2.6.patch
new file mode 100644
index 000000000000..4f39ce03e2ff
--- /dev/null
+++ b/dev-haskell/testpack/files/testpack-2.1.2.1-quickcheck-2.6.patch
@@ -0,0 +1,45 @@
+--- testpack-2.1.2.1-orig/testpack.cabal 2013-02-26 02:03:46.000000000 +1100
++++ testpack-2.1.2.1/testpack.cabal 2013-03-14 12:10:12.741512817 +1100
+@@ -39,7 +39,7 @@
+
+ Build-Depends: base >= 3 && < 5,
+ mtl, HUnit,
+- QuickCheck >= 2.1.0.3 && < 2.5
++ QuickCheck >= 2.1.0.3
+
+ If flag(splitBase)
+ Build-Depends: base >= 3 && < 5, containers, random
+--- testpack-2.1.2-quickcheck-2.5/src/Test/HUnit/Tools.hs 2012-07-09 09:03:53.104931180 +1000
++++ testpack-2.1.2.1/src/Test/HUnit/Tools.hs 2013-03-14 12:51:13.403489351 +1100
+@@ -169,10 +169,15 @@
+ -- | Tests a property, using test arguments, produces a test result, and prints the results to 'stdout'.
+ localquickCheckWithResult :: Testable prop => Args -> prop -> IO Result
+ localquickCheckWithResult args p =
+- do
+ #if MIN_VERSION_QuickCheck(2,3,0)
++#if MIN_VERSION_QuickCheck(2,6,0)
++ (if chatty args then withStdioTerminal else withNullTerminal) $ \tm -> do
++#else
++ do
+ tm <- if chatty args then newStdioTerminal else newNullTerminal
++#endif
+ #else
++ do
+ tm <- newTerminal
+ #endif
+ rnd <- case replay args of
+--- testpack-2.1.2.1-orig/src/Test/QuickCheck/Tools.hs 2013-02-26 02:03:46.000000000 +1100
++++ testpack-2.1.2.1/src/Test/QuickCheck/Tools.hs 2013-03-14 12:46:14.922492197 +1100
+@@ -23,8 +23,12 @@
+
+ )
+ where
++#if MIN_VERSION_QuickCheck(2,6,0)
++import Test.QuickCheck.Property (Result(..), callbacks, expect, interrupted, ok, reason, stamp)
++#else
+ import Test.QuickCheck hiding (Result, reason)
+ import Test.QuickCheck.Property
++#endif
+
+ {- | Compare two values. If same, the test passes. If different, the result indicates
+ what was expected and what was received as part of the error. -}
diff --git a/dev-haskell/testpack/testpack-2.1.2.1.ebuild b/dev-haskell/testpack/testpack-2.1.2.1.ebuild
new file mode 100644
index 000000000000..e83a49297dbb
--- /dev/null
+++ b/dev-haskell/testpack/testpack-2.1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/testpack/testpack-2.1.2.1.ebuild,v 1.1 2013/04/02 13:01:19 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Test Utililty Pack for HUnit and QuickCheck"
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/testpack"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/quickcheck-2.1.0.3:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-2.1.2-quickcheck-2.5.patch"
+ "${FILESDIR}/${PN}-2.1.2.1-quickcheck-2.6.patch")