summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-13 10:03:12 +0000
committerMark Wright <gienah@gentoo.org>2013-09-13 10:03:12 +0000
commit627dce8e27a0d260631d74d20776349226756c55 (patch)
treee89cffc1fae4055d2fd7789f956b16e447e8319a /dev-haskell/logict
parentSync with overlay: add ~ppc ~ppc64 ~sparc keywords (diff)
downloadgentoo-2-627dce8e27a0d260631d74d20776349226756c55.tar.gz
gentoo-2-627dce8e27a0d260631d74d20776349226756c55.tar.bz2
gentoo-2-627dce8e27a0d260631d74d20776349226756c55.zip
Add logict
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/logict')
-rw-r--r--dev-haskell/logict/ChangeLog9
-rw-r--r--dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch20
-rw-r--r--dev-haskell/logict/logict-0.6.0.1.ebuild27
-rw-r--r--dev-haskell/logict/metadata.xml15
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/logict/ChangeLog b/dev-haskell/logict/ChangeLog
new file mode 100644
index 000000000000..630445e068bc
--- /dev/null
+++ b/dev-haskell/logict/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/logict
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/logict/ChangeLog,v 1.1 2013/09/13 10:03:12 gienah Exp $
+
+*logict-0.6.0.1 (13 Sep 2013)
+
+ 13 Sep 2013; Mark Wright <gienah@gentoo.org>
+ +files/logict-0.5.0-ghc-6.12.patch, +logict-0.6.0.1.ebuild, +metadata.xml:
+ Add logict
diff --git a/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch b/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch
new file mode 100644
index 000000000000..7e2449494e96
--- /dev/null
+++ b/dev-haskell/logict/files/logict-0.5.0-ghc-6.12.patch
@@ -0,0 +1,20 @@
+--- logict-0.5.0-orig/Control/Monad/Logic.hs 2011-07-30 02:23:36.000000000 +1000
++++ logict-0.5.0/Control/Monad/Logic.hs 2012-01-06 20:53:00.424125711 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, MultiParamTypeClasses #-}
++{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, MultiParamTypeClasses, CPP #-}
+
+ -------------------------------------------------------------------------
+ -- |
+@@ -155,6 +155,11 @@
+ where
+ ssk a fk = return $ Just (a, (lift fk >>= reflect))
+
++#if !MIN_VERSION_mtl(2,0,0)
++instance F.Foldable Identity where
++ foldMap f (Identity x) = f x
++#endif
++
+ instance (Monad m, F.Foldable m) => F.Foldable (LogicT m) where
+ foldMap f m = F.fold $ unLogicT m (liftM . mappend . f) (return mempty)
+
diff --git a/dev-haskell/logict/logict-0.6.0.1.ebuild b/dev-haskell/logict/logict-0.6.0.1.ebuild
new file mode 100644
index 000000000000..41004b4e118a
--- /dev/null
+++ b/dev-haskell/logict/logict-0.6.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/logict/logict-0.6.0.1.ebuild,v 1.1 2013/09/13 10:03:12 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A backtracking logic-programming monad."
+HOMEPAGE="http://code.haskell.org/~dolio/logict"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-0"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.0-ghc-6.12.patch") \ No newline at end of file
diff --git a/dev-haskell/logict/metadata.xml b/dev-haskell/logict/metadata.xml
new file mode 100644
index 000000000000..c4d2cac84b1d
--- /dev/null
+++ b/dev-haskell/logict/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A continuation-based, backtracking, logic programming monad.
+ An adaptation of the two-continuation implementation found
+ in the paper &quot;Backtracking, Interleaving, and Terminating
+ Monad Transformers&quot; available here:
+ &lt;http://okmij.org/ftp/papers/LogicT.pdf&gt;
+ </longdescription>
+</pkgmetadata>