summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:38:42 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:38:42 +0000
commite02da8cacaa35c9236261deabc3a42463042f5f4 (patch)
tree1da12824fe579ca857e21587d58578eb404575e6 /dev-haskell/http-reverse-proxy
parentdev-haskell/project-template: initial layout (diff)
downloadgentoo-2-e02da8cacaa35c9236261deabc3a42463042f5f4.tar.gz
gentoo-2-e02da8cacaa35c9236261deabc3a42463042f5f4.tar.bz2
gentoo-2-e02da8cacaa35c9236261deabc3a42463042f5f4.zip
dev-haskell/http-reverse-proxy: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/http-reverse-proxy')
-rw-r--r--dev-haskell/http-reverse-proxy/ChangeLog11
-rw-r--r--dev-haskell/http-reverse-proxy/http-reverse-proxy-0.1.1.6.ebuild41
-rw-r--r--dev-haskell/http-reverse-proxy/http-reverse-proxy-0.2.0.ebuild42
-rw-r--r--dev-haskell/http-reverse-proxy/metadata.xml11
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-haskell/http-reverse-proxy/ChangeLog b/dev-haskell/http-reverse-proxy/ChangeLog
new file mode 100644
index 000000000000..6d4f93e04e70
--- /dev/null
+++ b/dev-haskell/http-reverse-proxy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/http-reverse-proxy
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-reverse-proxy/ChangeLog,v 1.1 2013/08/26 12:38:42 qnikst Exp $
+
+*http-reverse-proxy-0.2.0 (26 Aug 2013)
+*http-reverse-proxy-0.1.1.6 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org>
+ +http-reverse-proxy-0.1.1.6.ebuild, +http-reverse-proxy-0.2.0.ebuild,
+ +metadata.xml:
+ dev-haskell/http-reverse-proxy: initial layout
diff --git a/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.1.1.6.ebuild b/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.1.1.6.ebuild
new file mode 100644
index 000000000000..570a7fcc953e
--- /dev/null
+++ b/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.1.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.1.1.6.ebuild,v 1.1 2013/08/26 12:38:42 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Reverse proxy HTTP requests, either over raw sockets or with WAI"
+HOMEPAGE="https://github.com/fpco/http-reverse-proxy"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.4:=[profile?]
+ >=dev-haskell/classy-prelude-0.3:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/http-conduit-1.6:=[profile?]
+ >=dev-haskell/http-types-0.6:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/network-conduit-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/warp-1.3.4:=[profile?]
+ >=dev-haskell/word8-0.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/transformers
+ )"
diff --git a/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.2.0.ebuild b/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.2.0.ebuild
new file mode 100644
index 000000000000..b65891f44994
--- /dev/null
+++ b/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.2.0.ebuild,v 1.1 2013/08/26 12:38:42 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Reverse proxy HTTP requests, either over raw sockets or with WAI"
+HOMEPAGE="https://github.com/fpco/http-reverse-proxy"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.4:=[profile?]
+ >=dev-haskell/classy-prelude-0.3:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/http-conduit-1.6:=[profile?]
+ >=dev-haskell/http-types-0.6:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/network-conduit-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/warp-1.3.4:=[profile?]
+ >=dev-haskell/word8-0.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/transformers
+ )"
diff --git a/dev-haskell/http-reverse-proxy/metadata.xml b/dev-haskell/http-reverse-proxy/metadata.xml
new file mode 100644
index 000000000000..21dd3357a831
--- /dev/null
+++ b/dev-haskell/http-reverse-proxy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Provides a simple means of reverse-proxying HTTP requests. The raw approach uses the same technique as leveraged by keter, whereas the WAI approach performs full request/response parsing via WAI and http-conduit.
+ </longdescription>
+</pkgmetadata>