summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2006-04-20 10:49:32 +0000
committerAndres Loeh <kosmikus@gentoo.org>2006-04-20 10:49:32 +0000
commit0918675c011aded9a45d241ab7330d3883da41f8 (patch)
tree189070eeb42a75e60af8642d177f17bda75f6e5f /dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
parentNew development snapshot. (diff)
downloadgentoo-2-0918675c011aded9a45d241ab7330d3883da41f8.tar.gz
gentoo-2-0918675c011aded9a45d241ab7330d3883da41f8.tar.bz2
gentoo-2-0918675c011aded9a45d241ab7330d3883da41f8.zip
Moved setup code to pkg_setup, hopefully fixing bug #130553.
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild')
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
index b2ce0edd9283..5389f8b77707 100644
--- a/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
+++ b/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild,v 1.4 2006/04/07 21:20:49 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.6.0.ebuild,v 1.5 2006/04/20 10:49:32 kosmikus Exp $
inherit base eutils multilib ghc-package
@@ -18,7 +18,9 @@ DEPEND=">=virtual/ghc-6.4
>=dev-haskell/haddock-0.6"
RDEPEND=""
-HSLIB="/usr/$(get_libdir)/${P}/ghc-$(ghc-version)/"
+pkg_setup() {
+ HSLIB="/usr/$(get_libdir)/${P}/ghc-$(ghc-version)/"
+}
src_unpack() {
base_src_unpack