summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-01 16:42:03 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-01 16:42:03 +0000
commitaaa36ef000e25e5a8bab54fb2ffd12f37a92d007 (patch)
treed0869d03573d7c95d304aceb065a89a9cb7ba2a2 /dev-haskell/hlint
parentVersion bump. Fixes bug 535882. (diff)
downloadgentoo-2-aaa36ef000e25e5a8bab54fb2ffd12f37a92d007.tar.gz
gentoo-2-aaa36ef000e25e5a8bab54fb2ffd12f37a92d007.tar.bz2
gentoo-2-aaa36ef000e25e5a8bab54fb2ffd12f37a92d007.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/hlint')
-rw-r--r--dev-haskell/hlint/ChangeLog9
-rw-r--r--dev-haskell/hlint/hlint-1.9.21.ebuild74
2 files changed, 81 insertions, 2 deletions
diff --git a/dev-haskell/hlint/ChangeLog b/dev-haskell/hlint/ChangeLog
index c1cd20c51078..2542660e2c7a 100644
--- a/dev-haskell/hlint/ChangeLog
+++ b/dev-haskell/hlint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hlint
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hlint/ChangeLog,v 1.5 2014/12/14 11:00:39 gienah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hlint/ChangeLog,v 1.6 2015/08/01 16:42:03 slyfox Exp $
+
+*hlint-1.9.21 (01 Aug 2015)
+
+ 01 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org> +hlint-1.9.21.ebuild:
+ Version bump.
*hlint-1.9.10 (14 Dec 2014)
diff --git a/dev-haskell/hlint/hlint-1.9.21.ebuild b/dev-haskell/hlint/hlint-1.9.21.ebuild
new file mode 100644
index 000000000000..164b45c486f7
--- /dev/null
+++ b/dev-haskell/hlint/hlint-1.9.21.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hlint/hlint-1.9.21.ebuild,v 1.1 2015/08/01 16:42:03 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal elisp-common
+
+DESCRIPTION="Source code suggestions"
+HOMEPAGE="http://community.haskell.org/~ndm/hlint/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +gpl"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
+ >=dev-haskell/cmdargs-0.10:=[profile?]
+ >=dev-haskell/cpphs-1.18.1:=[profile?]
+ >=dev-haskell/extra-0.5:2=[profile?]
+ >=dev-haskell/haskell-src-exts-1.16:=[profile?] <dev-haskell/haskell-src-exts-1.17:=[profile?]
+ >=dev-haskell/transformers-0.0:=[profile?]
+ >=dev-haskell/uniplate-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ gpl? ( >=dev-haskell/hscolour-1.21:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_configure() {
+ local threaded_flag=""
+ if $(ghc-supports-threaded-runtime); then
+ threaded_flag="--flags=threaded"
+ else
+ threaded_flag="--flags=-threaded"
+ fi
+
+ haskell-cabal_src_configure \
+ $(cabal_flag gpl gpl) \
+ $threaded_flag
+}
+
+src_compile() {
+ cabal_src_compile
+
+ use emacs && elisp-compile data/hs-lint.el
+}
+
+src_install() {
+ cabal_src_install
+
+ if use emacs; then
+ elisp-install ${PN} data/*.el data/*.elc || die "elisp-install failed."
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ doman data/hlint.1
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}