summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 06:02:01 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 06:02:01 +0000
commita8b487d46884e5a858d44f6fe9e4e52a7a973ac2 (patch)
tree471f9a0c367bafadf4ea85660524dd46cde8f1ed /dev-haskell/highlighting-kate
parentBump hamlet to 1.1.7.5 (diff)
downloadgentoo-2-a8b487d46884e5a858d44f6fe9e4e52a7a973ac2.tar.gz
gentoo-2-a8b487d46884e5a858d44f6fe9e4e52a7a973ac2.tar.bz2
gentoo-2-a8b487d46884e5a858d44f6fe9e4e52a7a973ac2.zip
Bump highlighting-kate to 0.5.5.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/highlighting-kate')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog8
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.5.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index b244e3c67727..767a35d7b3fc 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.13 2013/11/24 19:33:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.14 2013/12/11 06:02:01 gienah Exp $
+
+*highlighting-kate-0.5.5.1 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org>
+ +highlighting-kate-0.5.5.1.ebuild:
+ Bump highlighting-kate to 0.5.5.1
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> highlighting-kate-0.5.5.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.1.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.1.ebuild
new file mode 100644
index 000000000000..1c0025ef0583
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.1.ebuild,v 1.1 2013/12/11 06:02:01 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}