summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-01 15:30:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-01 15:30:24 +0000
commit1e4b129ad7c133e797c065bc931c6a4005f1a2b8 (patch)
treef141650f5289604688b805c3308c1fa11906b0a9 /dev-haskell/hashable
parentVersion bump. (diff)
downloadgentoo-2-1e4b129ad7c133e797c065bc931c6a4005f1a2b8.tar.gz
gentoo-2-1e4b129ad7c133e797c065bc931c6a4005f1a2b8.tar.bz2
gentoo-2-1e4b129ad7c133e797c065bc931c6a4005f1a2b8.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/hashable')
-rw-r--r--dev-haskell/hashable/ChangeLog7
-rw-r--r--dev-haskell/hashable/hashable-1.2.3.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-haskell/hashable/ChangeLog b/dev-haskell/hashable/ChangeLog
index 259418c9eabd..5ff7d7477d62 100644
--- a/dev-haskell/hashable/ChangeLog
+++ b/dev-haskell/hashable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hashable
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashable/ChangeLog,v 1.35 2015/07/31 10:35:24 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashable/ChangeLog,v 1.36 2015/08/01 15:30:24 slyfox Exp $
+
+*hashable-1.2.3.3 (01 Aug 2015)
+
+ 01 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org> +hashable-1.2.3.3.ebuild:
+ Version bump.
31 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> hashable-1.2.1.0.ebuild:
ia64 stable wrt bug #495380
diff --git a/dev-haskell/hashable/hashable-1.2.3.3.ebuild b/dev-haskell/hashable/hashable-1.2.3.3.ebuild
new file mode 100644
index 000000000000..159d5e1010ed
--- /dev/null
+++ b/dev-haskell/hashable/hashable-1.2.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashable/hashable-1.2.3.3.ebuild,v 1.1 2015/08/01 15:30:24 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -sse2,-sse41,integer-gmp:gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A class for types that can be converted to a hash value"
+HOMEPAGE="http://github.com/tibbe/hashable"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gmp"
+
+RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag gmp integer-gmp) \
+ --flag=-sse2 \
+ --flag=-sse41
+}