summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:25:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:25:26 +0000
commit6181aa94df97e7a23d283b2a6553947294ca8342 (patch)
tree31271f0904c2f0b696184bb9526eecb80f49528b /dev-haskell/dbus-core
parentVersion bump. (diff)
downloadgentoo-2-6181aa94df97e7a23d283b2a6553947294ca8342.tar.gz
gentoo-2-6181aa94df97e7a23d283b2a6553947294ca8342.tar.bz2
gentoo-2-6181aa94df97e7a23d283b2a6553947294ca8342.zip
Version bump.
(Portage version: 2.2.0_alpha149_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/dbus-core')
-rw-r--r--dev-haskell/dbus-core/ChangeLog8
-rw-r--r--dev-haskell/dbus-core/dbus-core-0.9.3-r1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-haskell/dbus-core/ChangeLog b/dev-haskell/dbus-core/ChangeLog
index de5799674dc4..427e4560df28 100644
--- a/dev-haskell/dbus-core/ChangeLog
+++ b/dev-haskell/dbus-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/dbus-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dbus-core/ChangeLog,v 1.2 2012/09/12 15:23:28 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dbus-core/ChangeLog,v 1.3 2012/12/22 21:25:26 slyfox Exp $
+
+*dbus-core-0.9.3-r1 (22 Dec 2012)
+
+ 22 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +dbus-core-0.9.3-r1.ebuild:
+ Version bump.
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> dbus-core-0.9.2.1.ebuild:
move dev-haskell/dbus-core/dbus-core-0.9.2.1.ebuild ebuild to mirror://hackage
diff --git a/dev-haskell/dbus-core/dbus-core-0.9.3-r1.ebuild b/dev-haskell/dbus-core/dbus-core-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..32bd3afb6a47
--- /dev/null
+++ b/dev-haskell/dbus-core/dbus-core-0.9.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dbus-core/dbus-core-0.9.3-r1.ebuild,v 1.1 2012/12/22 21:25:26 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Low-level D-Bus protocol implementation"
+HOMEPAGE="https://john-millikin.com/software/dbus-core/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
+ <dev-haskell/binary-0.7:=[profile?]
+ >=dev-haskell/data-binary-ieee754-0.3:=[profile?]
+ <dev-haskell/data-binary-ieee754-0.5:=[profile?]
+ =dev-haskell/libxml-sax-0.7*:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ <dev-haskell/network-2.5:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?]
+ <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ <dev-haskell/vector-0.11:=[profile?]
+ =dev-haskell/xml-types-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ if has_version "<dev-haskell/haddock-2.9.2"; then
+ # Workaround http://hackage.haskell.org/trac/hackage/ticket/626
+ # The haddock --hoogle option does not like unicode characters, which causes
+ # haddock 2.7.2 to fail like:
+ # haddock: internal Haddock or GHC error: dist/doc/html/enumerator/enumerator.txt: commitAndReleaseBuffer: invalid argument (Invalid or incomplete multibyte or wide character)
+ sed -e 's@&#8208;@-@g' \
+ -e "s@&#8217;@'@g" \
+ -i "${S}/hs/DBus/Connection.hs" \
+ -i "${S}/hs/DBus/Client/Internal.hs" \
+ -i "${S}/hs/DBus/Client/Simple.hs" \
+ -i "${S}/hs/DBus/Message/Internal.hs" \
+ -i "${S}/hs/DBus/Types/Internal.hs" \
+ -i "${S}/hs/DBus/Wire/Internal.hs"
+ fi
+ sed -e 's@bytestring >= 0.9 && < 0.10@bytestring@' \
+ -e 's@containers >= 0.1 && < 0.5@containers@' \
+ -e 's@unix >= 2.2 && < 2.6@unix@' \
+ -e 's@network >= 2.2 && < 2.4@network >= 2.2 \&\& < 2.5@' \
+ -e 's@vector >= 0.7 && < 0.10@vector@' \
+ -e 's@binary >= 0.4 && < 0.6@binary >= 0.4 \&\& < 0.7@' \
+ -i "${S}/${PN}.cabal"
+}