summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-14 16:32:23 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-14 16:32:23 +0000
commit9d589dfa3bfdb56694d6d2e947cd51d6b48e6647 (patch)
tree726e2e9d729822a0a9004558d3dd58497ff448eb /dev-haskell/dav
parentnew version, bug #504602 (diff)
downloadgentoo-2-9d589dfa3bfdb56694d6d2e947cd51d6b48e6647.tar.gz
gentoo-2-9d589dfa3bfdb56694d6d2e947cd51d6b48e6647.tar.bz2
gentoo-2-9d589dfa3bfdb56694d6d2e947cd51d6b48e6647.zip
bump new versions, bug #504602
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/dav')
-rw-r--r--dev-haskell/dav/ChangeLog11
-rw-r--r--dev-haskell/dav/dav-0.5.1.ebuild (renamed from dev-haskell/dav/dav-0.5.ebuild)6
-rw-r--r--dev-haskell/dav/dav-0.6.1.ebuild46
3 files changed, 58 insertions, 5 deletions
diff --git a/dev-haskell/dav/ChangeLog b/dev-haskell/dav/ChangeLog
index 45c65037570c..d20dff3d8725 100644
--- a/dev-haskell/dav/ChangeLog
+++ b/dev-haskell/dav/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/dav
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/ChangeLog,v 1.2 2013/12/11 13:25:34 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/ChangeLog,v 1.3 2014/03/14 16:32:23 qnikst Exp $
+
+*dav-0.6.1 (14 Mar 2014)
+*dav-0.5.1 (14 Mar 2014)
+
+ 14 Mar 2014; Alexander Vershilov <qnikst@gentoo.org> +dav-0.5.1.ebuild,
+ +dav-0.6.1.ebuild, -dav-0.5.ebuild:
+ bump new versions, bug #504602
*dav-0.5 (11 Dec 2013)
diff --git a/dev-haskell/dav/dav-0.5.ebuild b/dev-haskell/dav/dav-0.5.1.ebuild
index 5567e179be0f..e6d5b7621927 100644
--- a/dev-haskell/dav/dav-0.5.ebuild
+++ b/dev-haskell/dav/dav-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/dav-0.5.ebuild,v 1.1 2013/12/11 13:25:34 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/dav-0.5.1.ebuild,v 1.1 2014/03/14 16:32:23 qnikst Exp $
EAPI=5
@@ -23,7 +23,7 @@ IUSE=""
RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
>=dev-haskell/http-client-0.2:=[profile?]
- >=dev-haskell/http-conduit-2:=[profile?]
+ >=dev-haskell/http-client-tls-0.2:=[profile?]
>=dev-haskell/http-types-0.7:=[profile?]
>=dev-haskell/lens-3.0:=[profile?]
>=dev-haskell/lifted-base-0.1:=[profile?]
diff --git a/dev-haskell/dav/dav-0.6.1.ebuild b/dev-haskell/dav/dav-0.6.1.ebuild
new file mode 100644
index 000000000000..8857cf20cd70
--- /dev/null
+++ b/dev-haskell/dav/dav-0.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/dav-0.6.1.ebuild,v 1.1 2014/03/14 16:32:23 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="DAV"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="RFC 4918 WebDAV support"
+HOMEPAGE="http://floss.scru.org/hDAV"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
+ >=dev-haskell/either-4.1:=[profile?]
+ dev-haskell/errors:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ >=dev-haskell/http-client-tls-0.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lens-3.0:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/optparse-applicative-0.5.0:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?] <=dev-haskell/xml-conduit-1.2:=[profile?]
+ >=dev-haskell/xml-hamlet-0.4:=[profile?] <=dev-haskell/xml-hamlet-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"