summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:42:07 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:42:07 +0000
commit4a7b3231626539b22b66cb194815a485038282a9 (patch)
treeb3b96af1768132c78bf0c8e5855e9c1186dd02e4 /dev-haskell/cabal/cabal-1.1.6.2.ebuild
parentalex-2.1 works with cabal 1.1.6 only, not cabal 1.2 (diff)
downloadgentoo-2-4a7b3231626539b22b66cb194815a485038282a9.tar.gz
gentoo-2-4a7b3231626539b22b66cb194815a485038282a9.tar.bz2
gentoo-2-4a7b3231626539b22b66cb194815a485038282a9.zip
Various minor maintanance changes. Remove unecessary blocker.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell/cabal/cabal-1.1.6.2.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-1.1.6.2.ebuild40
1 files changed, 15 insertions, 25 deletions
diff --git a/dev-haskell/cabal/cabal-1.1.6.2.ebuild b/dev-haskell/cabal/cabal-1.1.6.2.ebuild
index 6c10f55f7661..08fa7eaf0c12 100644
--- a/dev-haskell/cabal/cabal-1.1.6.2.ebuild
+++ b/dev-haskell/cabal/cabal-1.1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.2.ebuild,v 1.9 2007/10/31 12:54:22 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.2.ebuild,v 1.10 2007/12/13 00:42:07 dcoutts Exp $
CABAL_FEATURES="bootstrap profile lib"
inherit haskell-cabal eutils
@@ -8,31 +8,26 @@ inherit haskell-cabal eutils
DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
HOMEPAGE="http://haskell.org/cabal"
SRC_URI="http://haskell.org/cabal/release/${P}/${P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-
KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
IUSE="doc"
DEPEND=">=dev-lang/ghc-6.2"
-GHC_PV="6.6.1"
+CABAL_CORE_LIB_GHC_PV="6.6.1"
src_unpack() {
- if test $(ghc-version) = ${GHC_PV}; then
- elog "cabal-${PV} is included in ghc-${GHC_PV}, nothing to install."
- else
- unpack "${A}"
- if ! $(ghc-cabal); then
- sed -i 's/Build-Depends: base/Build-Depends: base, unix/' \
- ${S}/Cabal.cabal
- fi
+ unpack "${A}"
+ if ! $(ghc-cabal); then
+ sed -i 's/Build-Depends: base/Build-Depends: base, unix/' \
+ "${S}/Cabal.cabal"
fi
}
src_compile() {
- if ! test $(ghc-version) = ${GHC_PV}; then
+ if ! cabal-is-dummy-lib; then
if ghc-cabal; then
make setup HC="$(ghc-getghc) -ignore-package Cabal"
else
@@ -44,19 +39,14 @@ src_compile() {
}
src_install() {
- if test $(ghc-version) = ${GHC_PV}; then
- dodir "$(ghc-confdir)"
- echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
- else
- cabal_src_install
+ cabal_src_install
- # documentation (install directly)
+ # documentation (install directly)
+ if use doc; then
dohtml -r doc/users-guide
- if use doc; then
- dohtml -r doc/API
- dohtml -r doc/pkg-spec-html
- dodoc doc/pkg-spec.pdf
- fi
- dodoc changelog copyright README releaseNotes TODO
+ dohtml -r doc/API
+ dohtml -r doc/pkg-spec-html
+ dodoc doc/pkg-spec.pdf
fi
+ dodoc changelog copyright README releaseNotes TODO
}