summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 06:26:11 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 06:26:11 +0000
commite5d80434ccfaebd6a7654fa2f4d3ae47336c55fb (patch)
tree572abbd5a900476c00a34ceba309e7b97bce4a22 /dev-haskell/aeson-pretty
parentBump criterion to 0.8.0.1 (diff)
downloadgentoo-2-e5d80434ccfaebd6a7654fa2f4d3ae47336c55fb.tar.gz
gentoo-2-e5d80434ccfaebd6a7654fa2f4d3ae47336c55fb.tar.bz2
gentoo-2-e5d80434ccfaebd6a7654fa2f4d3ae47336c55fb.zip
Bump aeson-pretty to 0.7.1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/aeson-pretty')
-rw-r--r--dev-haskell/aeson-pretty/ChangeLog9
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-haskell/aeson-pretty/ChangeLog b/dev-haskell/aeson-pretty/ChangeLog
index 9799ec01031c..04969a9b8f26 100644
--- a/dev-haskell/aeson-pretty/ChangeLog
+++ b/dev-haskell/aeson-pretty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/aeson-pretty
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson-pretty/ChangeLog,v 1.1 2013/11/20 14:16:39 slyfox Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson-pretty/ChangeLog,v 1.2 2014/03/09 06:26:11 gienah Exp $
+
+*aeson-pretty-0.7.1 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +aeson-pretty-0.7.1.ebuild:
+ Bump aeson-pretty to 0.7.1
*aeson-pretty-0.7 (20 Nov 2013)
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild
new file mode 100644
index 000000000000..ef36ee0b2c6f
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson-pretty/aeson-pretty-0.7.1.ebuild,v 1.1 2014/03/09 06:26:11 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool."
+HOMEPAGE="http://github.com/informatikr/aeson-pretty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.3.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ !lib-only? ( >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}