summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-05 17:41:50 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-08-05 17:41:50 +0000
commitda4f7f3bf11dcbea4efb20bb90eea15e17b7ba14 (patch)
treecec75a8ac4b12e26d1a09d02753fedf3223fb84b /dev-go
parentadd support for golang-vcs-snapshot to live ebuild (diff)
downloadgentoo-2-da4f7f3bf11dcbea4efb20bb90eea15e17b7ba14.tar.gz
gentoo-2-da4f7f3bf11dcbea4efb20bb90eea15e17b7ba14.tar.bz2
gentoo-2-da4f7f3bf11dcbea4efb20bb90eea15e17b7ba14.zip
add support for golang-vcs-snapshot to live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-spew/ChangeLog5
-rw-r--r--dev-go/go-spew/go-spew-9999.ebuild37
2 files changed, 6 insertions, 36 deletions
diff --git a/dev-go/go-spew/ChangeLog b/dev-go/go-spew/ChangeLog
index 4c1792fe1bf7..394d267db1ea 100644
--- a/dev-go/go-spew/ChangeLog
+++ b/dev-go/go-spew/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-spew
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/ChangeLog,v 1.2 2015/07/31 02:16:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/ChangeLog,v 1.3 2015/08/05 17:41:50 williamh Exp $
+
+ 05 Aug 2015; William Hubbs <williamh@gentoo.org> go-spew-9999.ebuild:
+ add support for golang-vcs-snapshot to live ebuild
31 Jul 2015; Patrick Lauer <patrick@gentoo.org> go-spew-0_pre20150619.ebuild,
go-spew-9999.ebuild:
diff --git a/dev-go/go-spew/go-spew-9999.ebuild b/dev-go/go-spew/go-spew-9999.ebuild
index 6fda3d38ae39..135f2813d828 100644
--- a/dev-go/go-spew/go-spew-9999.ebuild
+++ b/dev-go/go-spew/go-spew-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/go-spew-9999.ebuild,v 1.2 2015/07/31 02:16:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-spew/go-spew-9999.ebuild,v 1.3 2015/08/05 17:41:50 williamh Exp $
EAPI=5
@@ -13,6 +13,7 @@ else
KEYWORDS="~amd64"
EGIT_COMMIT="2df174808ee097f90d259e432cc04442cf60be21"
SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -23,37 +24,3 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=""
RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
-src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
- golang-build_src_install
-}