summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-23 12:27:02 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-23 12:27:02 +0000
commit92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b (patch)
tree1573c450a4f23d5acfc12a1e4c84cc74c91df0b4 /dev-games
parentFix some ewarn calls for the upcoming net-dns/bind-9.4.3_p5-r1 bump. (diff)
downloadgentoo-2-92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b.tar.gz
gentoo-2-92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b.tar.bz2
gentoo-2-92b65ed0a027ad36bc10dfbdae531cdb1e5b6e8b.zip
Respect LDFLAGS (for all the ebuild that use it). Bug #337869
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/KXL/ChangeLog11
-rw-r--r--dev-games/KXL/KXL-1.1.7-r2.ebuild30
-rw-r--r--dev-games/KXL/files/KXL-1.1.7-ldflags.patch10
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-games/KXL/ChangeLog b/dev-games/KXL/ChangeLog
index 25ded3178160..75fff3c23d69 100644
--- a/dev-games/KXL/ChangeLog
+++ b/dev-games/KXL/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-games/KXL
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/ChangeLog,v 1.13 2009/06/09 20:13:47 fmccor Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/ChangeLog,v 1.14 2010/09/23 12:27:02 tupone Exp $
+
+*KXL-1.1.7-r2 (23 Sep 2010)
+
+ 23 Sep 2010; Tupone Alfredo <tupone@gentoo.org> +KXL-1.1.7-r2.ebuild,
+ +files/KXL-1.1.7-ldflags.patch:
+ Respect LDFLAGS (for all the ebuild that use it). Bug #337869 by
+ flameeyes@gentoo.org
09 Jun 2009; Ferris McCormick <fmccor@gentoo.org> KXL-1.1.7-r1.ebuild:
Sparc stable, Bug #272429.
diff --git a/dev-games/KXL/KXL-1.1.7-r2.ebuild b/dev-games/KXL/KXL-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..b8ddc0638482
--- /dev/null
+++ b/dev-games/KXL/KXL-1.1.7-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/KXL-1.1.7-r2.ebuild,v 1.1 2010/09/23 12:27:02 tupone Exp $
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Development Library for making games for X"
+HOMEPAGE="http://kxl.orz.hm/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}
diff --git a/dev-games/KXL/files/KXL-1.1.7-ldflags.patch b/dev-games/KXL/files/KXL-1.1.7-ldflags.patch
new file mode 100644
index 000000000000..e628b5d2170f
--- /dev/null
+++ b/dev-games/KXL/files/KXL-1.1.7-ldflags.patch
@@ -0,0 +1,10 @@
+--- KXL.m4.old 2010-09-23 14:20:45.000000000 +0200
++++ KXL.m4 2010-09-23 14:21:08.000000000 +0200
+@@ -29,7 +29,6 @@
+
+ dnl add the KXL library
+ KXL_LIBS="$KXL_LIBS -lKXL"
+-LDFLAGS="$KXL_LIBS"
+ AC_MSG_RESULT($KXL_LIBS)
+
+ AC_PATH_XTRA