summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-10-28 23:31:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-10-28 23:31:47 +0000
commit081cfece28a717de5a9d096c7cff5c3ed1114aff (patch)
treecd76830ba4bc8e79c31b0a8eb2dbe90dd1c7aff1 /dev-games
parentversion bump wrt #461280, also allow parallel installation (diff)
downloadgentoo-2-081cfece28a717de5a9d096c7cff5c3ed1114aff.tar.gz
gentoo-2-081cfece28a717de5a9d096c7cff5c3ed1114aff.tar.bz2
gentoo-2-081cfece28a717de5a9d096c7cff5c3ed1114aff.zip
version bump and apply upstream patch to stable to fix building with newer mesa (bug #447258)
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/ChangeLog10
-rw-r--r--dev-games/clanlib/clanlib-2.3.6.ebuild6
-rw-r--r--dev-games/clanlib/clanlib-2.3.7.ebuild90
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.6-mesa.patch14
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-autotools.patch45
5 files changed, 161 insertions, 4 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index b7b133e515f2..71ed4a36efa6 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-games/clanlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.63 2013/01/31 00:19:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.64 2013/10/28 23:31:47 mr_bones_ Exp $
+
+*clanlib-2.3.7 (28 Oct 2013)
+
+ 28 Oct 2013; Michael Sterrett <mr_bones_@gentoo.org> +clanlib-2.3.7.ebuild,
+ +files/clanlib-2.3.6-mesa.patch, +files/clanlib-2.3.7-autotools.patch,
+ clanlib-2.3.6.ebuild:
+ version bump and apply upstream patch to stable to fix building with newer
+ mesa (bug #447258)
31 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -clanlib-2.3.4.ebuild,
-files/clanlib-2.3.4-autotools.patch:
diff --git a/dev-games/clanlib/clanlib-2.3.6.ebuild b/dev-games/clanlib/clanlib-2.3.6.ebuild
index 559ac67fc499..d7487c4223dd 100644
--- a/dev-games/clanlib/clanlib-2.3.6.ebuild
+++ b/dev-games/clanlib/clanlib-2.3.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.6.ebuild,v 1.4 2012/12/04 11:16:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.6.ebuild,v 1.5 2013/10/28 23:31:47 mr_bones_ Exp $
EAPI=4
inherit flag-o-matic eutils autotools-utils
@@ -44,7 +44,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
-PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+PATCHES=( "${FILESDIR}"/${P}-{autotools,mesa}.patch )
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
DOCS=(
diff --git a/dev-games/clanlib/clanlib-2.3.7.ebuild b/dev-games/clanlib/clanlib-2.3.7.ebuild
new file mode 100644
index 000000000000..95713d2b00d4
--- /dev/null
+++ b/dev-games/clanlib/clanlib-2.3.7.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.7.ebuild,v 1.1 2013/10/28 23:31:47 mr_bones_ Exp $
+
+EAPI=4
+inherit flag-o-matic eutils autotools-utils
+
+MY_P=ClanLib-${PV}
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="2.3"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="doc ipv6 mikmod opengl sound sqlite sse2 static-libs vorbis X"
+REQUIRED_USE="opengl? ( X )"
+
+RDEPEND="sys-libs/zlib
+ X? (
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/freetype
+ media-libs/fontconfig
+ opengl? ( virtual/opengl )
+ app-arch/bzip2
+ x11-libs/libX11
+ )
+ sqlite? ( dev-db/sqlite )
+ sound? ( media-libs/alsa-lib )
+ mikmod? (
+ media-libs/libmikmod
+ media-libs/alsa-lib
+ )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/alsa-lib
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=(
+ CODING_STYLE
+ CREDITS
+ PATCHES
+ README
+)
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanGL1)
+ $(use_enable opengl clanGUI)
+ $(use_enable X clanDisplay)
+ $(use_enable vorbis clanVorbis)
+ $(use_enable mikmod clanMikMod)
+ $(use_enable sqlite clanSqlite)
+ $(use_enable ipv6 getaddr)
+ )
+ use sound \
+ || use vorbis \
+ || use mikmod \
+ || myeconfargs+=( --disable-clanSound )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+# html files are keeped in a directory that is dependent on the SLOT
+# so to keep eventual bookmarks to the doc from version to version
+src_install() {
+ autotools-utils_src_install
+ if use doc ; then
+ emake DESTDIR="${D}" install-html
+ dodoc -r Examples Resources
+ fi
+}
diff --git a/dev-games/clanlib/files/clanlib-2.3.6-mesa.patch b/dev-games/clanlib/files/clanlib-2.3.6-mesa.patch
new file mode 100644
index 000000000000..bd98492b9b46
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.6-mesa.patch
@@ -0,0 +1,14 @@
+--- ClanLib-2.3.6.orig/Sources/API/GL1/opengl1_defines.h
++++ ClanLib-2.3.6/Sources/API/GL1/opengl1_defines.h
+@@ -44,6 +44,11 @@
+ #ifndef CL_DISPLAYDEFINES_DEFINES
+ #define CL_DISPLAYDEFINES_DEFINES
+
++/* newer Mesa defines this and creates a conflict */
++#ifdef GL_TYPE
++#undef GL_TYPE
++#endif
++
+ #include <cstddef>
+
+ #ifndef __APPLE__
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
new file mode 100644
index 000000000000..97db79ac4245
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
@@ -0,0 +1,45 @@
+--- Documentation/Reference/Makefile.am.old 2012-09-25 10:39:25.973544935 +0200
++++ Documentation/Reference/Makefile.am 2012-09-25 10:39:42.560554053 +0200
+@@ -10,7 +10,7 @@
+ mkdir doxyoutput;
+ mkdir reftest
+ doxygen ./clanlib.doxygen
+- make -C ../Utilities/ReferenceDocs
++ $(MAKE) -C ../Utilities/ReferenceDocs
+ ../Utilities/ReferenceDocs/ReferenceDocs
+
+ install-html:
+--- configure.ac.old 2012-09-25 11:07:38.412537590 +0200
++++ configure.ac 2012-09-25 11:09:41.133939131 +0200
+@@ -337,11 +337,9 @@
+
+ dnl Optional linux/joystick.h
+ AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
+- AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
+
+ dnl Optional linux/input.h
+ AC_CHECK_HEADERS(linux/input.h, linux_input=yes)
+- AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ if test "$WIN32" = "no" && test "$enable_clanDisplay" != "no"; then
+ CLANLIB_CHECK_LIB(fontconfig, [`cat $srcdir/Setup/Tests/fontconfig.cpp`], clanDisplay, [ *** Cannot find fontconfig (See http://fontconfig.org/ ) (Try libfontconfig1-dev or better) ], [-lfontconfig])
+@@ -358,6 +356,8 @@
+ clanDisplay, [ *** Cannot find version 8 of DirectInput], [-ldxguid -lole32 -ldinput8])
+ fi
+ fi
++AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
++AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ have_xrender=no
+
+@@ -515,9 +515,9 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanSound" != "no"; then
+ enable_clanSound=yes