summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-12 23:05:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-12 23:05:13 +0000
commit8afff1c5bf5ead2b69db2c9215608d74b7a14e11 (patch)
tree040d0dfcf735926514ae8b0624cd6813ebc43a71 /dev-games/wfmath
parentstable arm, bug #434082 (diff)
downloadgentoo-2-8afff1c5bf5ead2b69db2c9215608d74b7a14e11.tar.gz
gentoo-2-8afff1c5bf5ead2b69db2c9215608d74b7a14e11.tar.bz2
gentoo-2-8afff1c5bf5ead2b69db2c9215608d74b7a14e11.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-games/wfmath')
-rw-r--r--dev-games/wfmath/ChangeLog8
-rw-r--r--dev-games/wfmath/wfmath-1.0.1.ebuild40
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-games/wfmath/ChangeLog b/dev-games/wfmath/ChangeLog
index 6320cbbb4eed..6ebad0aeffb4 100644
--- a/dev-games/wfmath/ChangeLog
+++ b/dev-games/wfmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/wfmath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.21 2012/10/31 09:25:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.22 2012/11/12 23:05:13 mr_bones_ Exp $
+
+*wfmath-1.0.1 (12 Nov 2012)
+
+ 12 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +wfmath-1.0.1.ebuild:
+ version bump
31 Oct 2012; Tupone Alfredo <tupone@gentoo.org> -wfmath-0.3.10.ebuild,
wfmath-0.3.11.ebuild, +files/wfmath-0.3.11-gcc47.patch, wfmath-1.0.0.ebuild:
@@ -86,4 +91,3 @@
01 Feb 2007; <tupone@gentoo.org> +metadata.xml, +wfmath-0.3.5.ebuild:
Initial ebuild, version 0.3.6 Bug #58213 by Boris Smus
-
diff --git a/dev-games/wfmath/wfmath-1.0.1.ebuild b/dev-games/wfmath/wfmath-1.0.1.ebuild
new file mode 100644
index 000000000000..39d62f7bd2e4
--- /dev/null
+++ b/dev-games/wfmath/wfmath-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-1.0.1.ebuild,v 1.1 2012/11/12 23:05:13 mr_bones_ Exp $
+
+EAPI=4
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ emake -C doc docs
+ fi
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml doc/html/*
+ fi
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+}