summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-19 01:44:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-19 01:44:57 +0000
commitc6f68dd4158b59d2078a85512d5bb8a51d8604b2 (patch)
treefa2dab770c6895b1990c534e6e4e0fd081f6a86d /dev-games/vamos
parentold (diff)
downloadgentoo-2-c6f68dd4158b59d2078a85512d5bb8a51d8604b2.tar.gz
gentoo-2-c6f68dd4158b59d2078a85512d5bb8a51d8604b2.tar.bz2
gentoo-2-c6f68dd4158b59d2078a85512d5bb8a51d8604b2.zip
add gcc43 patch submitted by Dannee McGuire (bug #227511)
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-games/vamos')
-rw-r--r--dev-games/vamos/ChangeLog6
-rw-r--r--dev-games/vamos/files/vamos-0.6.0-gcc43.patch31
-rw-r--r--dev-games/vamos/vamos-0.6.0.ebuild13
3 files changed, 47 insertions, 3 deletions
diff --git a/dev-games/vamos/ChangeLog b/dev-games/vamos/ChangeLog
index 98027d2c80c0..1bcc93369198 100644
--- a/dev-games/vamos/ChangeLog
+++ b/dev-games/vamos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/vamos
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/ChangeLog,v 1.7 2008/02/24 07:08:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/ChangeLog,v 1.8 2008/08/19 01:44:56 mr_bones_ Exp $
+
+ 19 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vamos-0.6.0-gcc43.patch, vamos-0.6.0.ebuild:
+ add gcc43 patch submitted by Dannee McGuire (bug #227511)
*vamos-0.6.0 (24 Feb 2008)
diff --git a/dev-games/vamos/files/vamos-0.6.0-gcc43.patch b/dev-games/vamos/files/vamos-0.6.0-gcc43.patch
new file mode 100644
index 000000000000..11404071f09b
--- /dev/null
+++ b/dev-games/vamos/files/vamos-0.6.0-gcc43.patch
@@ -0,0 +1,31 @@
+--- caelum/Sky.cc
++++ caelum/Sky.cc
+@@ -19,6 +19,7 @@
+ #include "Sky.h"
+
+ #include <cassert>
++#include <cstdlib>
+
+ #include <SDL/SDL.h>
+ #include <GL/glut.h>
+--- track/Gl_Road_Segment.cc
++++ track/Gl_Road_Segment.cc
+@@ -22,6 +22,7 @@
+
+ #include <GL/glut.h>
+
++#include <algorithm>
+ #include <cassert>
+
+ using namespace Vamos_Track;
+--- vamos/vamos.cc
++++ vamos/vamos.cc
+@@ -24,6 +24,8 @@
+ #include "../world/Gl_World.h"
+ #include "../world/Sounds.h"
+
++#include <cstdlib>
++
+ using namespace Vamos_Geometry;
+ using namespace Vamos_Media;
+
diff --git a/dev-games/vamos/vamos-0.6.0.ebuild b/dev-games/vamos/vamos-0.6.0.ebuild
index e18757aae441..4d71f28d8e52 100644
--- a/dev-games/vamos/vamos-0.6.0.ebuild
+++ b/dev-games/vamos/vamos-0.6.0.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/vamos-0.6.0.ebuild,v 1.1 2008/02/24 07:08:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/vamos/vamos-0.6.0.ebuild,v 1.2 2008/08/19 01:44:56 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils
DESCRIPTION="an automotive simulation framework"
HOMEPAGE="http://vamos.sourceforge.net/"
@@ -19,7 +22,13 @@ DEPEND="virtual/opengl
media-libs/sdl-ttf
media-libs/openal
media-libs/freealut
- =dev-libs/libsigc++-1.2*"
+ dev-libs/libsigc++:1.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
src_compile() {
econf \